This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167097 - gpilotd will not accept port of net:any
gpilotd will not accept port of net:any
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-30 06:01 EDT by Jake Gage
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-pilot-2.0.15-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 15:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb backtrace of crash when hitting OK after setting sync type to network (10.86 KB, text/plain)
2006-01-17 09:16 EST, Thomas J. Baker
no flags Details

  None (edit)
Description Jake Gage 2005-08-30 06:01:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Fedora/1.7.10-1.5.1

Description of problem:
Sorry to bug, but I can't seem to get gpilotd to listen on a network port.  Tests with pilot-xfer ("pilot-xfer --port net: --list", etc.) seem to work very well, as does JPilot with the PILOTPORT environment variable set to "net:any". 

I'm attempting to edit the ~/.gnome2/gnome-pilot-d/gpilotd configuration file in such a way:

[General]
sync_PC_Id=630334926
progress_stepping=5
num_devices=1
num_pilots=1

[Device0]
type=1
name=Cradle
device=net:
speed=57600
timeout=2

[Pilot0]
name=MyPilot
pilotid=500
creation=0
romversion=0
pilotusername=Jake Gage
basedir=/home/jake/MyPilot

  I've tried numerous configurations, but none of them seem to work.  If this is a documentation bug, I'm sorry, but I can't seem to find a way to get Gnome or Evolution synching via network interface.

  Any help at all would be appreciated, and I'm happy to supply any more information that might be helpful.

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.13-2

How reproducible:
Always

Steps to Reproduce:
1.  Run the Gnome pilot configuration tool to get a sample ~/.gnome2/gnome-pilot-d/gpilotd configuration file.
2.  killall gpilotd and verify file changes
3.  Attempt to reconfigure gpilotd to listen on "net:", "net:<ip_address>", or "net:any" (also using various types, IP configurations, whatnot).
4.  restart gpilotd and attempt to hotsync, read the palm user and device ID, whatnot...
5.  No response after lengthy gpilotd output about network listening.
  

Actual Results:  gpilotd will not respond to network sync requests

Expected Results:  gpilotd would respond to network sync requests

Additional info:
Comment 1 Thomas J. Baker 2005-10-25 11:27:17 EDT
I got this to work somewhat. Device settings in gpilotd file that worked for me
were these:

[Device0]
type=1
name=LifeDrive
device=net:any
speed=115200
timeout=10

Comment 2 Matt Davey 2006-01-17 04:57:54 EST
See also bug #161824.  The workaround above only works with a usb-cable
connected device.  It 'wakes' gpilotd with via usb, and gpilotd then
completes the sync by passing the net:any device to pilot-link.
gnome-pilot doesn't listen correctly for network packets at the moment.

I have a patched version available, from
http://www.inference.phy.cam.ac.uk/mcdavey/downloads.html
if you would like to assist with testing.
Comment 3 Thomas J. Baker 2006-01-17 09:15:24 EST
I had to rebuild from the src rpm since I'm on x86_64. Once I got past the
crasher on trying to set it to be a network sync from "Pilot Settings" caplet
(I'll include a bt next), grepped the source to find out that network sync was
type 4, set it by hand in ~/.gnome2/gnome-pilotd.d/gpilotd, it then seemed to
sync fine. It doesn't seem to list the evolution pilot conduits in "Pilot
Settings" but I'll rebuild evolution with the new -devel to see if that restores
them.
Comment 4 Thomas J. Baker 2006-01-17 09:16:18 EST
Created attachment 123291 [details]
gdb backtrace of crash when hitting OK after setting sync type to network
Comment 5 Thomas J. Baker 2006-01-17 11:26:57 EST
A rebuilt evolution does not make the evolution conduits seen. Any hints? With
out the evo conduits, netsync is a lot less exciting.
Comment 6 Thomas J. Baker 2006-01-17 13:59:51 EST
P.S. The correct URL for the patch is
http://www.inference.phy.cam.ac.uk/mcdavey/downloads (drop the .html)
Comment 7 Matt Davey 2006-01-25 03:55:58 EST
Sorry for the delay getting back to you (I hadn't added myself to the cc list).

The evolution package puts the .conduit files into /usr/lib/gnome-pilot/
conduits.  Move them into /usr/share/gnome-pilot/conduits and the evo
conduits should show up.  I've added a note to the download page.

Thanks for the bug report and workaround.  Smells like a buffer overrun?
I'd better try running with valgrind.
Comment 8 Andrew 2006-09-29 18:16:39 EDT
I think the new 2.0.14 version (released Sept 8) fixes this problem.  
Comment 9 Andrew 2006-10-03 12:16:59 EDT
I built and installed pilot-link 2.0.14 for Fedora Core 5, and I can confirm it
solves this issue.  Now the sync over the network does work.
Comment 10 Matthew Barnes 2006-12-13 15:10:04 EST
gnome-pilot-2.0.15 is now in Fedora Core 6.

Closing this bug based on comment #8 and comment #9.  Please re-open this bug if
you find that the problem still exists.

Note You need to log in before you can comment on or make changes to this bug.