Bug 167120 - up2date attempts to install package that is already installed (javamail), and generates an error
up2date attempts to install package that is already installed (javamail), and...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
Depends On:
Blocks: 168424 169775
  Show dependency treegraph
 
Reported: 2005-08-30 12:12 EDT by chris suttles
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0105
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris suttles 2005-08-30 12:12:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
# up2date -u
Invalid metapkg id emacs-nox
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching Obsoletes list for channel: rhel-i386-as-3-extras...
 
Fetching Obsoletes list for channel: rhel-3-as-i386-rhaps-1...
 
Fetching Obsoletes list for channel: rhel-3-as-i386-rhds-2...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
javamail                                1.3.1          1jpp_4rh          noarch
 

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package javamail-1.3.1-1jpp_4rh is already installed


Version-Release number of selected component (if applicable):
up2date-4.2.57-2 

How reproducible:
Always

Steps to Reproduce:
1. subscribe to rhel-as-i386-rhaps-1
2. install javamail* packages
3. run up2date -u
  

Actual Results:  # up2date -u
Invalid metapkg id emacs-nox
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching Obsoletes list for channel: rhel-i386-as-3-extras...
 
Fetching Obsoletes list for channel: rhel-3-as-i386-rhaps-1...
 
Fetching Obsoletes list for channel: rhel-3-as-i386-rhds-2...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
javamail                                1.3.1          1jpp_4rh          noarch
 

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package javamail-1.3.1-1jpp_4rh is already installed


Expected Results:  up2date should exit with a 0 status, and indicated all packages are up to date.

Additional info:

In troubleshooting this issue, we have: 

1. rm -rf /var/spool/up2date/*
2. rm -rf /var/lib/rpm/__db.00*
3. rpmdb --rebuilddb 
4. up2date -p

still nogo. 

Removed javamail, and dependencies, reinstalled them via up2date, up2date -p.

still nogo. 

Reinstalled up2date with --replacepkgs 

Adding javamail to packages skip list causes up2date to function correctly.
Comment 3 Adrian Likins 2005-11-09 16:53:00 EST
Hmm, interesting. javamail obsoletes javamail-monolithic. 

Why they are then in the same channel is a good question. up2date will always
attempt to replace javamail-monolithic with javamail, so the packaging here
seems a bit bogus. 

Since it seems the packages don't actually obsolete as much as they conflict
(aka, both shouldn't be installed at the same time) javamail should have a
conflict on javamail-obsolete. 

I'm also not sure I understand the reasoning for having a set of packages, and
then a single package that encompasses everything from multiple packages.

There is a up2date bug, however, in that it's not properly detecting that an
available obsoleting package is already installed (though, that in itself implys
that the system has both a package installed, and a package that obsoletes it,
which is kind of off kilter to begin with).

However, a similar bug to this was fixed with the update 4.4 for rhel3 in U2, so
this should be resolved with the rhel3u2 update. 

Can the customer duplicate this with the currrent U3 up2date?
Comment 4 Adrian Likins 2006-01-06 14:02:36 EST
looks to be a packaging bug, so closing 
Comment 7 Red Hat Bugzilla 2006-03-15 10:33:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0105.html

Note You need to log in before you can comment on or make changes to this bug.