Bug 1671482 - cmake fails do build doxygen documentaion because of windows line endings
Summary: cmake fails do build doxygen documentaion because of windows line endings
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cmake
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: https://gitlab.kitware.com/cmake/cmak...
Whiteboard:
: 1674745 1675311 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-01-31 16:56 UTC by Andreas Schneider
Modified: 2019-02-12 13:31 UTC (History)
7 users (show)

Fixed In Version: cmake-3.13.4-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-03 05:11:28 UTC


Attachments (Terms of Use)

Description Andreas Schneider 2019-01-31 16:56:05 UTC
Description of problem:

cmake provides a module to generate doxygen documentation:

find_package(Doxygen)

This module creates a CMakeDoxygenDefaults.cmake in the build root which seems to add Windows line endings (\m)

cmake fails with:

BUILDSTDERR: CMake Error at obj/CMakeDoxygenDefaults.cmake:471 (set):
BUILDSTDERR:   Syntax error in cmake code at
BUILDSTDERR:     /builddir/build/BUILD/libssh-0.8.6/obj/CMakeDoxygenDefaults.cmake:471
BUILDSTDERR:   when parsing string
BUILDSTDERR:     \makeindex
BUILDSTDERR:   Invalid character escape '\m'.
BUILDSTDERR: Call Stack (most recent call first):
BUILDSTDERR:   /usr/share/cmake/Modules/FindDoxygen.cmake:958 (include)
BUILDSTDERR:   doc/CMakeLists.txt:40 (doxygen_add_docs)


https://koji.fedoraproject.org/koji/taskinfo?taskID=32375115

Comment 1 Orion Poplawski 2019-02-03 05:11:28 UTC
Upstream bug: https://gitlab.kitware.com/cmake/cmake/issues/18738

Fix: https://gitlab.kitware.com/cmake/cmake/merge_requests/2867

Fixed in 3.13.4, build hopefully finishing shortly.

Comment 2 Andreas Schneider 2019-02-11 18:19:14 UTC
*** Bug 1674745 has been marked as a duplicate of this bug. ***

Comment 3 Andreas Schneider 2019-02-12 13:31:29 UTC
*** Bug 1675311 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.