This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167182 - file picker crashes on navigation to a directory
file picker crashes on navigation to a directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
http://www.openoffice.org/issues/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 08:45 EDT by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 10:43:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2005-08-31 08:45:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050815 Fedora/1.7.11-2

Description of problem:
as reported at http://www.openoffice.org/issues/show_bug.cgi?id=53881 on FC4 and openoffice.org 1.9.125 navigation to a directory in file picker crashes with stacktrace

Version-Release number of selected component (if applicable):
gtk2-2.6.7-4

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. see http://www.openoffice.org/issues/show_bug.cgi?id=53881

Additional info:

related bugs:

http://bugzilla.gnome.org/show_bug.cgi?id=314033
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165970

stack-trace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208506688 (LWP 2860)]
0x00bdec1a in strcmp () from /lib/libc.so.6
(gdb) bt
#0  0x00bdec1a in strcmp () from /lib/libc.so.6
#1  0x06d83eff in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#2  0x06d84dcc in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#3  0x06d8b45d in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#4  0x05475817 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x0546a285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#6  0x0547878b in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#7  0x05479ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#8  0x0547a254 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#9  0x06e87498 in gtk_tree_selection_select_range ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x06e9900e in gtk_tree_view_scroll_to_cell ()
   from /usr/lib/libgtk-x11-2.0.so.0
#11 0x06e9f5b7 in gtk_tree_view_set_cursor_on_cell ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x06e9f670 in gtk_tree_view_set_cursor () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x06d88b16 in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#14 0x05475817 in g_cclosure_marshal_VOID__VOID ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libgobject-2.0.so.0
#15 0x0546a285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#16 0x0547878b in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#17 0x05479ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#18 0x0547a254 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#19 0x06d96576 in gtk_file_folder_list_children ()
   from /usr/lib/libgtk-x11-2.0.so.0
#20 0x05475817 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#21 0x0546a285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0x0547878b in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#23 0x05479ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0x0547ca40 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#25 0x05c71b2c in gtk_file_system_gnome_vfs_new ()
   from /usr/lib/gtk-2.0/2.4.0/filesystems/libgnome-vfs.so
#26 0x01d270c9 in _gnome_vfs_job_go () from /usr/lib/libgnomevfs-2.so.0
#27 0x02a3a650 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#28 0x02a383ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0x02a3b3f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#30 0x02a3b6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#31 0x06d666d1 in gtk_dialog_run () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x027c79c1 in ?? ()
   from /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so
---Type <return> to continue, or q <return> to quit---
#33 0x027c7a05 in ?? ()
   from /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so
#34 0x02a39f06 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#35 0x02a383ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x02a3b3f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#37 0x02a3b8d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0x017195f9 in ?? ()
   from /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so
#39 0x00000000 in ?? ()
(gdb)
Comment 1 Steve Milton 2005-10-25 17:23:39 EDT
This appears to specifically be a problem with gtk2.  This bug also occurs with
Fedora Core 4 on x86_64 arch, with openoffice.org 2.0.0-3.2.1

Workaround:  If you go into the OpenOffice-2.0, Tools -> Options -> General
settings, you can select the "Use OpenOffice.org Dialogs" option to change the
behavior to not crash OOo.
Comment 2 Steve Milton 2005-10-25 17:29:13 EDT
BTW, the relevant RPMS that I have installed are:

openoffice.org-impress-2.0.0-3.2.1      i386
openoffice.org-calc-2.0.0-3.2.1         i386
openoffice.org-core-2.0.0-3.2.1         i386

gtk2-2.6.10-2   x86_64
gtk2-2.6.10-2   i386

There are reports that Gtk2 version 2.8.0 or higher fixes this issue.
Comment 3 Caolan McNamara 2006-08-12 10:43:36 EDT
lets throw this out, we never reproduced it and we've moved on since then, no
reports of this in FC-5 or to-be FC-6

Note You need to log in before you can comment on or make changes to this bug.