Bug 16719 - dependency problem in glibc-devel-2.1.92-5
dependency problem in glibc-devel-2.1.92-5
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-22 08:52 EDT by Bernhard Ege
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 08:52:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Ege 2000-08-22 08:52:42 EDT
I was having problems compiling the kernel (kernel-source-2.2.16-21) and
figured that the problem was that I had installed (actually upgraded to)
kernel-headers-2.4.0-0.21. This lead me to try en uninstall kernel-headers,
but glibc-devel wouldn't let me. I figure the kernel-source was enough to
satisfy glibc-devel, but apparently, the kernel-headers for kernel 2.4 has
to be installed. This cannot be right? I mean, if I install the kernel
headers for 2.4 then I cannot compile the kernel (there are problems
including these headers).

So, to sum up, shouldn't the dependency for glibc-devel be satisfied by
either kernel-headers *or* kernel-source, not just kernel-headers?

If kernel-headers are the only ones required, why isn't there any
kernel-headers for the 2.2.16-21 kernel?

regards,

Bernhard Ege
Comment 1 Bill Nottingham 2000-08-22 12:03:07 EDT
Having kernel-headers-2.4.0 installed should have no
effect on compiling the kernel. It is intentional
for the 2.4 kernel headers to be required by glibc, as
that's what glibc was built against.

Note You need to log in before you can comment on or make changes to this bug.