Bug 167217 - ip.sh should ignore non-UP interfaces
ip.sh should ignore non-UP interfaces
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks: 164915
  Show dependency treegraph
 
Reported: 2005-08-31 13:17 EDT by Lon Hohberger
Modified: 2009-04-16 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: rgmanager-1.9.46-0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 06:45:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes bz and includes handling of DOWNed interfaces (11.44 KB, patch)
2005-09-16 12:17 EDT, Stanko Kupcevic
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2005-08-31 13:17:21 EDT
Description of problem:

ip.sh currently checks all interfaces for a matching IP in the subnet.  If eth0
has a matching IP but the cable is pulled, while eth1 has a matching IP and IS
up, the ip resource will fail to start since the link of eth0 is not up.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure eth0 with 10.1.1.2
2. Configure eth1 with 10.1.1.3
3. Unplug eth0
4. Run:
   OCF_RESKEY_address=10.1.1.4 OCF_RESKEY_monitor_link=1 \
      /usr/share/cluster/ip.sh start
  
Actual results:
Fail to start


Expected results:
IP address assigned to eth1.


Additional info:
Comment 1 Stanko Kupcevic 2005-09-16 12:17:14 EDT
Created attachment 118900 [details]
Fixes bz and includes handling of DOWNed interfaces

Patch attached
Comment 2 Stanko Kupcevic 2005-09-16 12:31:34 EDT
Patch in CVS, setting to modified
Comment 3 Lon Hohberger 2006-05-09 06:45:24 EDT
This was fixed in U3; I don't know why it's still open.

Note You need to log in before you can comment on or make changes to this bug.