Bug 167283 - Cannot rebuild php, gcc problem
Cannot rebuild php, gcc problem
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-09-01 04:48 EDT by Uros Kositer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-01 05:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
rpm build output (20.04 KB, text/plain)
2005-09-01 04:50 EDT, Uros Kositer
no flags Details

  None (edit)
Description Uros Kositer 2005-09-01 04:48:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1

Description of problem:
When I try to rebuild php with oci8 support I get following error:

+ make -j4
make: *** No targets specified and no makefile found.  Stop.
napaka: Bad exit status from /var/tmp/rpm-tmp.20135 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.20135 (%build)

I have inspected rpm output and found some problem with gcc:
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables

I then tried to rebuild php without oci8 support and got same error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpmbuild --rebuild --define '_with_oci8 1' /var/spool/up2date/php-4.3.9-3.8.src.rpm

Actual Results:  Same error

Expected Results:  php-oci8 rpm

Additional info:
Comment 1 Uros Kositer 2005-09-01 04:50:11 EDT
Created attachment 118339 [details]
rpm build output
Comment 2 Joe Orton 2005-09-01 05:53:46 EDT
The compile log shows you have this version of gcc installed:

gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47.3)

this is an old version (from RHEL3?) which cannot be used to build RHEL4 packages.

I suggest you update to the RHEL4 gcc, for example using "up2date -u gcc"

Note You need to log in before you can comment on or make changes to this bug.