Bug 167309 - newest vim updates segfault editing files
newest vim updates segfault editing files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 10:51 EDT by Chris Ricker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 13:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of a segfault (82.91 KB, text/plain)
2005-09-01 10:51 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2005-09-01 10:51:28 EDT
[kaboom@slartibartfast bin]$ rpm -q vim-minimal vim-common vim-enhanced
vim-minimal-6.3.086-0.fc4
vim-common-6.3.086-0.fc4
vim-enhanced-6.3.086-0.fc4
[kaboom@slartibartfast bin]$ 

vim segfaults editing any file. Files open fine, but as soon as I press any
command key (j, i, etc.) it segfaults

this only happens running actual vim command. vi (vim minimal mode) doesn't segfault

this happens for all users, and even after I remove any existing ~/.viminfo files
Comment 1 Chris Ricker 2005-09-01 10:51:28 EDT
Created attachment 118344 [details]
strace of a segfault
Comment 2 Chris Ricker 2005-09-01 10:58:32 EDT
Here's the backtrace

[kaboom@slartibartfast ~]$ gdb vim core.6788 
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x111000
Core was generated by `vim bin/yumdate.sh'.
Program terminated with signal 11, Segmentation fault.

warning: svr4_current_sos: Can't read pathname for load map: Input/output error

Reading symbols from /usr/lib/libncurses.so.5...done.
Loaded symbols for /usr/lib/libncurses.so.5
Reading symbols from /lib/libselinux.so.1...done.
Loaded symbols for /lib/libselinux.so.1
Reading symbols from /lib/libacl.so.1...done.
Loaded symbols for /lib/libacl.so.1
Reading symbols from /usr/lib/libgpm.so.1...done.
Loaded symbols for /usr/lib/libgpm.so.1
Reading symbols from
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so...done.
Loaded symbols for /usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so
Reading symbols from /lib/libresolv.so.2...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /lib/libutil.so.1...done.
Loaded symbols for /lib/libutil.so.1
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/libpthread.so.0...done.
Loaded symbols for /lib/libpthread.so.0
Reading symbols from /lib/libattr.so.1...done.
Loaded symbols for /lib/libattr.so.1
Reading symbols from /lib/libnsl.so.1...done.
Loaded symbols for /lib/libnsl.so.1
Reading symbols from /lib/libcrypt.so.1...done.
Loaded symbols for /lib/libcrypt.so.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libnss_files.so.2...done.
Loaded symbols for /lib/libnss_files.so.2
#0  0x00111402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00111402 in __kernel_vsyscall ()
#1  0x006be586 in kill () from /lib/libc.so.6
#2  0x081117dc in may_core_dump () at os_unix.c:2741
#3  0x08111d22 in mch_exit (r=0) at os_unix.c:2718
#4  0x080e3893 in preserve_exit () at misc1.c:7607
#5  <signal handler called>
#6  0x08084a07 in set_vcount (count=0, count1=0) at eval.c:7886
#7  0x080fc7df in normal_cmd (oap=0xbfbfcfe4, toplevel=1) at normal.c:762
#8  0x080ca260 in main_loop (cmdwin=0) at main.c:2183
#9  0x080cf46a in main (argc=0, argv=0x968c280) at main.c:2001
(gdb) 
Comment 3 Karsten Hopp 2005-09-05 10:12:51 EDT
I cannot reproduce this on a freshly installed FC4 with all updates applied.
Please make sure you have the latest available updates on your system, i.e.
ncurses, glibc and libselinux.
Comment 4 Chris Ricker 2005-09-06 12:30:12 EDT
it's fully updated

[root@slartibartfast ~]# yum update
Setting up Update Process
Setting up repositories
livna                     100% |=========================|  951 B    00:00     
updates-released          100% |=========================|  951 B    00:00     
updates-testing           100% |=========================|  951 B    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
base                      100% |=========================| 1.1 kB    00:00     
livna-testing             100% |=========================|  951 B    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  22 kB    00:00     
updates-te: ################################################## 90/90
Added 28 new packages, deleted 21 old in 0.19 seconds
No Packages marked for Update/Obsoletion
[root@slartibartfast ~]# rpm -q glibc ncurses libselinux
glibc-2.3.5-10.3
ncurses-5.4-17
libselinux-1.23.10-2
[root@slartibartfast ~]# vim test
Vim: Caught deadly signal SEGV

Vim: Finished.
Segmentation fault
[root@slartibartfast ~]# 
Comment 5 Karsten Hopp 2005-10-12 05:14:39 EDT
Is this reproducable with vim-6.3.090-2 from Rawhide ?
Comment 6 Chris Ricker 2005-10-14 13:11:12 EDT
rebooting for a new errata kernel fixed it

Note You need to log in before you can comment on or make changes to this bug.