Bug 167368 - HWCERT: Hewlett-Packard cx2600
HWCERT: Hewlett-Packard cx2600
Status: CLOSED DEFERRED
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: dumpster (Show other bugs)
2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Chris Williams
http://search.hp.com/redirect.html?ty...
Hewlett-Packard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 18:03 EDT by Rick Hester
Modified: 2007-08-22 15:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 15:09:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
QuickSpec for the cx2600 (38.82 KB, application/pdf)
2005-09-19 10:46 EDT, Rick Hester
no flags Details

  None (edit)
Description Rick Hester 2005-09-01 18:03:53 EDT
Red Hat Hardware Certification Submitted

Product:        Red Hat Enterprise Linux
Version:        4
Make:           Hewlett-Packard
Model:          rx2600
Vendor:         Hewlett Packard
Category:       Server
Reporter:       rick.hester@hp.com
Kernel Version: kernel-2.6.9-5.EL

File Uploaded:
rhr2-rx2600-Nahant_results-InfoCoreMemUsbVideoCdrom.noarch.rpm
https://bugzilla.redhat.com/hwcert/data/rpms/7537b9c403f6b75a02703bfa1e7b1e91/rhr2-rx2600-Nahant_results-InfoCoreMemUsbVideoCdrom.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.

0   FAILED   USB
    PASSED   INFO
    PASSED   VIDEO
    PASSED   MEMORY
    PASSED   CORE
1   FAILED   USB
    PASSED   INFO
    PASSED   CDROM
2   FAILED   USB
    PASSED   INFO
3   PASSED   USB
    PASSED   INFO
Comment 1 Rick Hester 2005-09-01 18:09:43 EDT
The cx2600 is an equivalent model to the rx2600.

I neglected to include the cx2600 when I submitted the RHEL 4 certification
results for the rx2600.  The cx2600 is the same server as the rx2600 but
it is in telecom-compliant (NEBS) packaging and uses  48VDC as the power
source.

The cx2600 only includes a subset of the processors supported by the 
rx2600 as well as a subset of the IO.   I will include copies of the
original rx2600 results that are relevant for cx2600.   But, I would 
hope that you do not need to spend any time on this since it is really
just another rx2600.


My last submission will be the list of accessories to results rpms.

Thanks
Comment 2 Rick Hester 2005-09-01 18:12:53 EDT
New Hardware Certification Package Submitted
Kernel Version: kernel-2.6.9-5.EL

File Uploaded:
rhr2-rx2620-Nahant_results-A9890A.noarch.rpm
https://bugzilla.redhat.com/hwcert/data/rpms/b426f12fa003ab5d3d0b09bd1c008c27/rhr2-rx2620-Nahant_results-A9890A.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.

0   PASSED   INFO
    PASSED   STORAGE
Comment 3 Rick Hester 2005-09-01 18:19:43 EDT
New Hardware Certification Package Submitted
Kernel Version: kernel-2.6.9-5.EL

File Uploaded:
rhr2-rx2620-Nahant_results-U320_int.noarch.rpm
https://bugzilla.redhat.com/hwcert/data/rpms/c05ab1d3bf5eddb41af1bf64e8fd5332/rhr2-rx2620-Nahant_results-U320_int.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.

0   PASSED   INFO
    PASSED   STORAGE
Comment 4 Rick Hester 2005-09-01 18:24:59 EDT
New Hardware Certification Package Submitted
Kernel Version: kernel-2.6.9-5.EL

File Uploaded:
rhr2-rx2600-Nahant_results-ee100-bcm5701Tx.noarch.rpm
https://bugzilla.redhat.com/hwcert/data/rpms/429ffe4644fc13d6fa478ea5736f82b2/rhr2-rx2600-Nahant_results-ee100-bcm5701Tx.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.

0   PASSED   INFO
    PASSED   NETWORK
Comment 5 Rick Hester 2005-09-01 18:26:17 EDT
New Hardware Certification Package Submitted
Kernel Version: kernel-2.6.9-5.EL

File Uploaded:
rhr2-rx4640-Nahant_results-A9899A_A9900A_A7061A_A7073A_A5506B.noarch.rpm
https://bugzilla.redhat.com/hwcert/data/rpms/ec01be0c9859a97ffd7262e18ea7b559/rhr2-rx4640-Nahant_results-A9899A_A9900A_A7061A_A7073A_A5506B.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.
FAILED: Incorrect memory amount

0   PASSED   INFO
    PASSED   NETWORK
Comment 7 Chris Williams 2005-09-02 09:18:43 EDT
Rick,
This cert should be for the cx2600 and not the rx2600? The system.conf indicates
this is a rx2600 which would back up your statement that this is just another
rx2600.
Looking at the devices you have tested, it appears they have all been previously
certed.

Can you provide a quickspec for the cx2600? I didn't find one on hp.com.
Comment 8 Rick Hester 2005-09-02 10:17:28 EDT
Chris,

I hope I didn't confuse things too much with this submittal.

> This cert should be for the cx2600 and not the rx2600?

Yes, when I certified the rx2600, I was not aware of the 
requirement to include the cx2600 model.

> The system.conf indicates this is a rx2600 which would 
> back up your statement that this is just another rx2600.

All I did was re-send the certification results that were 
run on an rx2600.   The results I posted in this submittal
are not new results run on the cx2600, they are just copies
of what I had previously submitted with the rx2600.  I had
thought that it might be convenient for you to have the 
in this submittal.  

> Looking at the devices you have tested, it appears they have 
> all been previously certed.

Yes, the devices that are supported for the cx2600 are a subset
of those supported in the rx2600.  

> Can you provide a quickspec for the cx2600? I didn't find one on hp.com.

A qucikspec does not exist for the cx2600.  The link I posted is about
as close to equivalent to a quickspec as is available for the cx2600.
There is also this link if that would work better - 
http://www.hp.com/products1/servers/carrier_grade/products/cx2600/specifications.html

I was thinking that the cx2600 could be paper certed based on the test
results from the rx2600.  The cx2600 is a repackaging of the rx2600 
system with no OS-visible changes from that repackaging.  Is this feasible?

Rick
Comment 9 Chris Williams 2005-09-14 14:15:33 EDT
Rick,
I think it will be faesible, but we need some better documentation on the
cx2600. Is there no quickspec for it?
Comment 10 Chris Williams 2005-09-14 14:23:56 EDT
Rick,
We can leverage most of the certs from the rx2600 testing, however, HWcert would
like to see that the cx2600 will install and run RHEL 4 so could you supply
INFO, CORE, MEMORY and NETWORK runs? We can leverage everything else.

The request for soem better docs on the cx2600 still stand as well.

Chris
Comment 11 Rick Hester 2005-09-19 10:45:00 EDT
Chris,

I did manage to locate a quickspec document on the cx2600.
There was one generated but the marketing guy has been fighting
with some of our 'processes' in getting in published on the 
web site.  So I'm attaching the pdf.

Here's the short summary of the commonality/differences between
the cx2600 and the rx2600 (which is already certified with RHEL4)

Same systemboard, Management Card, PCI, I/O, CPU.

Mostly the same firmware - only difference is how the server deals with temperature.

Different power input, number and size of fans.


Given that commonality, does HWcert really need to see any tests
run on the cx2600?  If they really feel like they need to, could
it just be the INFO, CORE, and MEMORY?  The NETWORK tests are a 
pain to set up and run in our environment.

Just to explain the motivation here;  we aren't expecting a huge
demand for RHEL4 on the cx2600.  It is a focused product on the
telecom market and usually has custom Linux put on it.  But, we
wanted to go ahead and have it listed so if some customers wanted
to buy Red Hat, we could sell it to them.  But given the low demand,
we are hoping to keep investment (on both HP's and Red Hat's part)
at a minimum.

Rick
Comment 12 Rick Hester 2005-09-19 10:46:37 EDT
Created attachment 118989 [details]
QuickSpec for the cx2600
Comment 13 Chris Williams 2005-09-19 11:03:53 EDT
Rick,
Do you think the  quickspecs will be published soon?

INFO, CORE, and MEMORY should be fine as long as the cx2600's LOM is exactly the
same as that  found in the rx2600. (sounds like it is, just want to make sure)

I understand about the investment factor.

Chris
Comment 14 Rick Hester 2005-09-19 11:37:29 EDT
Chris,

I think the marketing guy gave up on getting the QuickSpec
posted.

What he does is sends it out whenever he gets a query.
(Most of the sales on these boxes usually get custom
attention anyway).  He pointed out to me that it had the
advantage of knowing who was looking at the box.

Rick 
Comment 15 Chris Williams 2005-09-19 11:45:03 EDT
Rick,

The problem with not having the quickspecs public is that the HWcert process
assumes there is technical documentation available. The customer can go the Red
Hat's HWcert site, see that the cx2600 is certed, go to the HWcert posting and
from there, access HP's quickspecs. This way we (Red Hat HWcert) don't have to
list everything that is certed, it is already listed in the public quickspecs.

Chris
Comment 16 Rick Hester 2005-10-12 11:14:26 EDT
Chris,

The marketing folks tell me that they are in the process
of publishing the quickspecs.  It is going to happen in
two phases.  The first will phase will be a partner-specific
site (not generally available to all).  But for the cx2600,
that will actually cover most of the customers for that server
because the target market is focused on the companies that are
served by this site.

The second phase will be to get the QuickSpec published on the 
fully public site.  I was not given an ETA on that activity.
It seems the marketing team for this server is not familiar with
the HP buearacracy involved, so it's been an uphill battle.

So, what are our options here?
1) is the current public web site sufficient for the interim, until
   we get the QuickSpec published?
2) if not, would a pointer to the restricted partner area be sufficient,
   since the majority interested in the this particular server would
   already have access to that?
3) wait until QuickSpec is available on the public site

Obviously, we would prefer option 1.
Comment 17 Rick Hester 2005-10-14 14:23:44 EDT
Here is the 
Comment 18 Rick Hester 2005-10-14 14:25:38 EDT
Here is the latest update from the cx2600 marketing team:
-----
I believe I've got commitment to have the cx2600 on the external QS WEB page.
It should be there by November.
-----

Once this has been done, will we be able to have the cx2600 listed
as certified for RHEL4?
Comment 19 Chris Williams 2005-10-14 14:35:22 EDT
Rick,
That is good news on the quickspecs.

As far as posting this, HWcert wanted INFO, CORE, MEMORY and NETWORK runs on the
cx2600, we can leverage everything else.

Chris
Comment 20 Rick Hester 2005-10-14 15:45:14 EDT
Chris,

Back in comment #13, it sounded like just running
INFO, CORE, and MEMORY were ok.  Did the NETWORK
test get added back?

Rick
Comment 21 Rick Hester 2005-10-14 15:46:07 EDT
Oh, and would it be possible to change the subject to cx2600
instead of rx2600?

Thanks
Comment 22 Chris Williams 2005-10-26 12:02:16 EDT
Rick,
Sorry for the delay. OK, yes, I see my statement in Comment #13, as long as the
LOM is exactly the same as that in the rx2600.

Chris
Comment 23 Rick Hester 2005-10-26 17:35:10 EDT
Chris,

Just to make sure I understand - what is an LOM?

Rick
Comment 24 Chris Williams 2005-10-27 09:24:04 EDT
LAN On Motherboard.
Comment 25 Rick Hester 2005-11-09 12:14:06 EST
Chris,

The QuickSpec for this product is now published:
http://h18000.www1.hp.com/products/quickspecs/12387_div/12387_div.PDF

If engineering still feels like we need to run the INFO, CORE and MEMORY
tests, I'll queue those up but not sure when I will be able to get them run.

Rick
Comment 26 Rick Hester 2006-02-02 15:56:25 EST
Update:  I haven't forgotten about the request to
run the INFO, CORE, and MEMORY tests for this certification.
I'm waiting on my management to align priorities amongst
competing tasks.  

Any problem with this item staying "in the queue" for now?
Comment 27 Rob Landry 2006-02-06 14:56:18 EST
Verified with cww, it's good with us if it stays in queue for now.  Otherwise
correcting ownership to reflect new process.
Comment 28 Chris Williams 2006-04-10 11:17:31 EDT
Greetings Rick,

Any updates on this one?
Comment 29 Rick Hester 2006-04-10 11:28:20 EDT
Chris,

The team that requested this is still trying to decide whether to finish the
process or not.   It's not a lot of work for me to finish - but I requested
they submit a work order for the activity and they keep fiddling around.  I've
got enough to do already so I haven't pushed them to make a decision.

Sorry to just leave this dangling - if it's a problem, go ahead and close it
and if they ever decide, I can always open up a new one

Rick
Comment 30 Chris Williams 2006-04-19 14:57:21 EDT
Rick,
HWcert suggested closing this BZ and creating a new BZ with an INFO run done on
the cx2600. Having done that _and_ confirming that the BIOS changes between the
rx2600 and the cx2600 were not extensive, we can go ahead an post this unit.
Comment 31 Rick Hester 2006-04-19 15:09:35 EDT
Ok.  Will do.

Note You need to log in before you can comment on or make changes to this bug.