Bug 167386 - evince 0.4.0 does not honor window size/position metadata
evince 0.4.0 does not honor window size/position metadata
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 04:10 EDT by Emmanuel Kowalski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 16:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch for evince-0.4.0 solves bug 167386 for me. (1017 bytes, patch)
2005-09-02 04:11 EDT, Emmanuel Kowalski
no flags Details | Diff

  None (edit)
Description Emmanuel Kowalski 2005-09-02 04:10:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The last update of evince keeps per-document metadata, including window
size and position.  These are updated when changed so they can be used as
default when the same file is opened later.  However this is not the case
with those settings; it _does_ work with the page number / zoom setting, 
however.



Version-Release number of selected component (if applicable):
evince-0.4.0-1.2

How reproducible:
Always

Steps to Reproduce:
1. Open a PDF file with evince
2. Modify the window size and the zoom level.
3. Close evince
4. Restart evince with the same file.

  

Actual Results:  The zoom level selected at step 2 is preserved, but the window size is
not.

Expected Results:  The window size after step 4 should be the one after step 2.

Additional info:

Fiddling with the source code, I managed to find a solution.
I will add the patch I used as an attachment;  since I am not an expert
GTK programmer, it might not be the ``right'' solution, but it works
for me...
Comment 1 Emmanuel Kowalski 2005-09-02 04:11:50 EDT
Created attachment 118379 [details]
This patch for evince-0.4.0 solves bug 167386 for me.
Comment 2 Kristian Høgsberg 2006-09-22 16:33:43 EDT
With evince 0.6, evince remebmer zoom level, window position and size and
position in the document without problems.

Note You need to log in before you can comment on or make changes to this bug.