Bug 167387 - sk98lin gigabit ethernet driver does not work in kernel-smp 2.6.12 1.1447_FC4
sk98lin gigabit ethernet driver does not work in kernel-smp 2.6.12 1.1447_FC4
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 05:28 EDT by Felix Maibaum
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 13:36:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Maibaum 2005-09-02 05:28:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Since the update to 1447 the network interface (Marvell yukon onboard ASUS P5P800) driven by sk98lin can't get a connection. Driver is loaded without errors, but interface can't get address via dhcp, manually assigned address does not work either.
Older kernel and knoppix both work fine, so the issue is neither hardware nor network infrastructure.

Version-Release number of selected component (if applicable):
2.6.12 1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1.install kernel-smp 2.6.12 1.1447_FC4
2.try to use network for anything

  

Actual Results:  failed miserably

Expected Results:  seen a website, downloaded some pictures, pinged some computers

Additional info:

no error messages whatsoever, except for the failure to obtain IP address at boot.
Tested on P4 with hyperthreading and smp kernel, not tested on uniprocessor kernel.
Comment 1 Felix Maibaum 2005-09-02 05:31:43 EDT
network card is connected to a TP/Fiber trnsceiver
Comment 2 Dave Jones 2005-09-23 21:22:20 EDT
does the skge driver work better ?
sk98lin is an older driver, and will eventually be obsoleted by skge.
Comment 3 Felix Maibaum 2005-09-26 04:05:36 EDT
I have uninstalled the kernel in question, and I have little occasion to test
anything on that machine, because it is in production use. Nevertheless I will
try to test this during the course of this week. 
If skge is the better module, shouldn't this be the one that is loaded
automatically by whatever package detects the Hardware?
Comment 4 Dave Jones 2005-09-26 15:24:31 EDT
as of fc5, it will use skge by default.
Comment 5 Dave Jones 2005-09-30 02:15:33 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 6 Dave Jones 2005-11-10 14:12:54 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 7 John W. Linville 2005-12-08 13:36:56 EST
Closed due to lack of response.  Please reopen when the requested information  
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.