Bug 167449 - multipath devices aren't created for partitions on multipathed disks
Summary: multipath devices aren't created for partitions on multipathed disks
Status: CLOSED DUPLICATE of bug 160227
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-02 18:06 UTC by Stoo Davies
Modified: 2010-01-12 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 14:23:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stoo Davies 2005-09-02 18:06:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050715 Firefox/1.0.5

Description of problem:
When multipath is run to discover multipathed devices and setup maps for them it only creates an entry under /dev/mapper for the disk device.  It doesn't create entries for the partitions on the disk.
 
Currently I'm adding these manually with kpartx, but it would be nice if it happened automatically when discovered.

I noticed that bug 160227 is similar, but the reply was about enhancements to initrd, I'm looking for enhancements after the boot, probably in udev?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Run multipath

Additional info:

Comment 1 Alasdair Kergon 2005-09-02 18:24:27 UTC
Do you still need to use dos-style partitioning, or can you use LVM for this,
which should provide more flexibility?

Comment 2 Stoo Davies 2005-09-02 18:44:04 UTC
Unfortunately I need to use both.


Comment 3 Alasdair Kergon 2005-10-03 14:23:14 UTC

*** This bug has been marked as a duplicate of 160227 ***


Note You need to log in before you can comment on or make changes to this bug.