Bug 167473 - When booting up get these messages:
When booting up get these messages:
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 17:57 EDT by Leo Canale
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 09:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leo Canale 2005-09-02 17:57:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Sep  2 17:25:43 localhost sendmail[2097]: NOQUEUE: SYSERR(root): /etc/mail/submit.cf: line 545: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
Sep  2 17:25:43 localhost sendmail[2100]: NOQUEUE: SYSERR(root): /etc/mail/submit.cf: line 545: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
Sep  2 17:26:01 localhost sendmail[2227]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 91: fileclass: cannot open '/etc/mail/local-host-names': World writable directory
Sep  2 17:26:01 localhost sendmail[2227]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 588: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
Sep  2 17:26:01 localhost sendmail[2230]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 91: fileclass: cannot open '/etc/mail/local-host-names': World writable directory
Sep  2 17:26:01 localhost sendmail[2230]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 588: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
Sep  2 17:26:01 localhost sm-msp-queue[2235]: NOQUEUE: SYSERR(root): /etc/mail/submit.cf: line 545: fileclass: cannot open '/etc/mail/trusted-users': World writable directory


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Checked file owner and right against FC3 and all looks the same
2.
3.
  

Actual Results:  Still no resolve.

Additional info:

Started showing up after updates on Aug 29th
Comment 1 Thomas Woerner 2005-09-05 12:37:17 EDT
Have you changed the file access permisssions of /etc or /etc/mail?

These should be:
drwxr-xr-x  87 root root 12288 Sep  5 18:11 /etc
drwxr-xr-x   3 root root  4096 Jul 29 19:13 /etc/mail

The writbale flag may not be set for group and others.
Comment 2 Leo Canale 2005-09-05 16:44:51 EDT
(In reply to comment #1)
> Have you changed the file access permisssions of /etc or /etc/mail?
> These should be:
> drwxr-xr-x  87 root root 12288 Sep  5 18:11 /etc
> drwxr-xr-x   3 root root  4096 Jul 29 19:13 /etc/mail
> The writbale flag may not be set for group and others.

Checked on these and their ok as you described
Comment 3 Thomas Woerner 2005-09-06 04:18:20 EDT
Is your / directory world writable?

Please post the result of "ls -lad / /etc /etc/mail".
Comment 4 Leo Canale 2005-09-06 16:06:30 EDT
[root@localhost ~]# ls -lad / /etc /etc/mail
drwsrwsrwt   44 root root  4096 Sep  5 16:28 /
drwxr-xr-x  119 root root 12288 Sep  5 17:43 /etc
drwxr-xr-x    3 root root  4096 Jul 22 20:16 /etc/mail
[root@localhost ~]#
Comment 5 Leo Canale 2005-09-06 16:09:57 EDT
[root@localhost ~]# ls -lad / /etc /etc/mail
drwsrwsrwt   44 root root  4096 Sep  5 16:28 /
drwxr-xr-x  119 root root 12288 Sep  5 17:43 /etc
drwxr-xr-x    3 root root  4096 Jul 22 20:16 /etc/mail
[root@localhost ~]#
Comment 6 Leo Canale 2005-09-06 17:45:01 EDT
(In reply to comment #5)
> [root@localhost ~]# ls -lad / /etc /etc/mail
> drwsrwsrwt   44 root root  4096 Sep  5 16:28 /
> drwxr-xr-x  119 root root 12288 Sep  5 17:43 /etc
> drwxr-xr-x    3 root root  4096 Jul 22 20:16 /etc/mail
> [root@localhost ~]#

Sorry about comment #5 fat fingers.
I changed / directory access permissions to:
[root@localhost ~]# chmod 755 /
[root@localhost ~]# ls -lad / 
drwxr-xr-x   44 root root  4096 Sep  5 16:28 /
That solved the sendmail errors on boot. 

What changed that after the updates I installed?
And why?

I am now getting auditd error not familiar with this daemon and what to do 
about it.


Comment 7 Thomas Woerner 2005-09-07 06:04:59 EDT
This should be:

# ls -lad /
drwxr-xr-x  23 root root 4096 Sep  5 17:27 /

Do you know 
- if sendmail was able to start before the update?
- which packages were updated? 
Comment 8 Leo Canale 2005-09-07 16:29:35 EDT
Yes sendmail was able to start before one of these updates

Fedora Core 4 Update: dbus-0.33-3.fc4.1 	2005-08-29
Fedora Core 4 Update: xen-2-20050823 	2005-08-29
Fedora Core 4 Update: policycoreutils-1.23.11-3.2 	2005-08-29
Fedora Core 4 Update: selinux-policy-targeted-1.25.4-10 	2005-08-29
Fedora Core 4 Update: kernel-2.6.12-1.1447_FC4 	2005-08-28
Fedora Core 4 Update: libsoup-2.2.3-4.FC4 	2005-08-26
Fedora Core 4 Update: openoffice.org-1.9.125-1.1.0.fc4 	2005-08-26
Fedora Core 4 Update: php-5.0.4-10.4 	2005-08-25
Fedora Core 4 Update: audit-1.0.3-1.fc4 	2005-08-25
Fedora Core 4 Update: pcre-5.0-4.1.fc4 	2005-08-24
Fedora Core 4 Update: eject-2.1.1-0.fc4.1 	2005-08-24
Fedora Core 4 Update: glibc-2.3.5-10.3 	2005-08-23
Fedora Core 4 Update: cvs-1.11.19-9 	2005-08-23
Fedora Core 4 Update: bind-9.3.1-10_FC4 	2005-08-23
Fedora Core 4 Update: diskdumputils-1.1.9-2 	2005-08-22
Fedora Core 4 Update: system-config-netboot-0.1.30-1_FC4 	2005-08-22
Fedora Core 4 Update: dhcpv6-0.10-14_FC4 	2005-08-22
Fedora Core 4 Update: squirrelmail-1.4.6-0.cvs20050812.1.fc4 	2005-08-22
Fedora Core 4 Update: libgal2-2.4.3-1.fc4 	2005-08-22
Fedora Core 4 Update: xpdf-3.01-0.FC4.1 	2005-08-22
Fedora Core 4 Update: MyODBC-2.50.39-25.FC4.1 	2005-08-22
Fedora Core 4 Update: slocate-2.7-22.fc4.1 	2005-08-22
Fedora Core 4 Update: redhat-rpm-config-8.0.34-1.1 	2005-08-17
Fedora Core 4 Update: epiphany-1.6.5-1 	2005-08-17
Fedora Core 4 Update: system-config-bind-4.0.0-30_FC4 	2005-08-17
Fedora Core 4 Update: tar-1.15.1-8.FC4 	2005-08-15
Fedora Core 4 Update: doxygen-1.4.4-0.fc4.1 	2005-08-15
Fedora Core 4 Update: kdbg-2.0.0-0.fc4.1 	2005-08-15
Fedora Core 4 Update: system-config-netboot-0.1.26-1_FC4 	2005-08-15
Fedora Core 4 Update: gstreamer-plugins-0.8.8-9 	2005-08-12
Fedora Core 4 Update: gaim-1.5.0-1.fc4 	2005-08-12
Fedora Core 4 Update: audit-1.0.2-3.FC4 	2005-08-11
Fedora Core 4 Update: mc-4.6.1a-0.11.FC4 	2005-08-11
Fedora Core 4 Update: vnc-4.1.1-10.1 	2005-08-11
Fedora Core 4 Update: kdeedu-3.4.2-0.fc4.2 	2005-08-11
Fedora Core 4 Update: evolution-2.2.3-2.fc4
Comment 9 Thomas Woerner 2006-07-14 09:53:20 EDT
There is no script in sendmail which could result in a permission change of "/"
and I do not know of a script in another package which does this change. I can
not reproduce this problem at all.

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.