Bug 1675006 - golang-github-Shopify-toxiproxy: FTBFS in Fedora rawhide/f30
Summary: golang-github-Shopify-toxiproxy: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-shopify-toxiproxy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:33 UTC by Fedora Release Engineering
Modified: 2019-02-14 09:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-14 09:15:34 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
state.log (717 bytes, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:33:23 UTC
golang-github-Shopify-toxiproxy failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32394420


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-Shopify-toxiproxy at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-Shopify-toxiproxy will be orphaned. Before branching of Fedora 31,
golang-github-Shopify-toxiproxy will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:33:26 UTC
Created attachment 1530233 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:33:27 UTC
Created attachment 1530234 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:33:28 UTC
Created attachment 1530235 [details]
state.log

Comment 4 Jakub Čajka 2019-02-12 08:57:04 UTC
For the record this has been caused by crash in tests on s390x:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
--- FAIL: TestBrowserGets403 (8.54s)
panic: runtime error: invalid memory address or nil pointer dereference [recovered]
	panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x2aa4001895c]
goroutine 93221 [running]:
testing.tRunner.func1(0xc0000ee500)
	/usr/lib/golang/src/testing/testing.go:827 +0x3cc
panic(0x2aa40172840, 0x2aa403e5ab0)
	/usr/lib/golang/src/runtime/panic.go:522 +0x1e0
github.com/Shopify/toxiproxy_test.TestBrowserGets403.func1(0x2aa4002b182, 0x15)
	/builddir/build/BUILD/toxiproxy-2.1.3/_build/src/github.com/Shopify/toxiproxy/api_test.go:48 +0x15c
github.com/Shopify/toxiproxy_test.WithServer(0xc0000ee500, 0xc000038798)
	/builddir/build/BUILD/toxiproxy-2.1.3/_build/src/github.com/Shopify/toxiproxy/api_test.go:36 +0x70
github.com/Shopify/toxiproxy_test.TestBrowserGets403(0xc0000ee500)
	/builddir/build/BUILD/toxiproxy-2.1.3/_build/src/github.com/Shopify/toxiproxy/api_test.go:40 +0x4a
testing.tRunner(0xc0000ee500, 0x2aa401d6bb8)
	/usr/lib/golang/src/testing/testing.go:862 +0xca
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x36a
exit status 2
FAIL	github.com/Shopify/toxiproxy	9.066s

Comment 5 Igor Gnatenko 2019-02-14 09:15:34 UTC
There has been at least one successfull build after mass rebuild.

golang-github-Shopify-toxiproxy-2.1.3-2.fc30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1188062


Note You need to log in before you can comment on or make changes to this bug.