Bug 1675015 - golang-github-eapache-go-resiliency: FTBFS in Fedora rawhide/f30
Summary: golang-github-eapache-go-resiliency: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-eapache-go-resiliency
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:34 UTC by Fedora Release Engineering
Modified: 2019-02-14 09:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-14 09:15:35 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details
state.log (733 bytes, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:34:18 UTC
golang-github-eapache-go-resiliency failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32395136


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-eapache-go-resiliency at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-eapache-go-resiliency will be orphaned. Before branching of Fedora 31,
golang-github-eapache-go-resiliency will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:34:20 UTC
Created attachment 1530260 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:34:22 UTC
Created attachment 1530261 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:34:23 UTC
Created attachment 1530262 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 12:10:47 UTC
Caused by tests failure on s390x:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
--- FAIL: TestBreakerStateTransitions (4.42s)
    breaker_test.go:105: circuit breaker is open
    breaker_test.go:105: circuit breaker is open
    breaker_test.go:110: circuit breaker is open
    breaker_test.go:114: circuit breaker is open
--- FAIL: TestBreakerAsyncStateTransitions (4.28s)
    breaker_test.go:173: circuit breaker is open
FAIL
exit status 1
FAIL	github.com/eapache/go-resiliency/breaker	15.090s

Comment 5 Igor Gnatenko 2019-02-14 09:15:35 UTC
There has been at least one successfull build after mass rebuild.

golang-github-eapache-go-resiliency-1.1.0-2.fc30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1188186


Note You need to log in before you can comment on or make changes to this bug.