Bug 1675025 - golang-github-hashicorp-go-retryablehttp: FTBFS in Fedora rawhide/f30
Summary: golang-github-hashicorp-go-retryablehttp: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-hashicorp-go-retryablehttp
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:35 UTC by Fedora Release Engineering
Modified: 2019-02-16 17:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-16 17:19:27 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
state.log (821 bytes, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:35:15 UTC
golang-github-hashicorp-go-retryablehttp failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32395746


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-hashicorp-go-retryablehttp at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-hashicorp-go-retryablehttp will be orphaned. Before branching of Fedora 31,
golang-github-hashicorp-go-retryablehttp will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:35:17 UTC
Created attachment 1530290 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:35:19 UTC
Created attachment 1530291 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:35:20 UTC
Created attachment 1530292 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 12:38:30 UTC
Caused by tests failure on s390x(seems like local network timeout/issue):
+ go-rpm-integration check -i github.com/hashicorp/go-retryablehttp -p /builddir/build/BUILDROOT/golang-github-hashicorp-go-retryablehttp-0-0.9.20180612git6e85be8.fc30.s390x -g /usr/share/gocode -b /builddir/build/BUILD/go-retryablehttp-6e85be8fee1dcaa02c0eaaac2df5a8fbecf94145/_build -r '.*example.*'
Testing: github.com/hashicorp/go-retryablehttp
Testing: "/builddir/build/BUILD/go-retryablehttp-6e85be8fee1dcaa02c0eaaac2df5a8fbecf94145/_build/src/github.com/hashicorp/go-retryablehttp"
+ GOPATH=/builddir/build/BUILD/go-retryablehttp-6e85be8fee1dcaa02c0eaaac2df5a8fbecf94145/_build:/usr/share/gocode
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 10ms (50 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 20ms (49 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 40ms (48 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (47 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (46 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (45 left)
2019/02/01 17:31:00 [ERR] PUT http://127.0.0.1:28934/v1/foo request failed: Put http://127.0.0.1:28934/v1/foo: dial tcp 127.0.0.1:28934: connect: connection refused
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (44 left)
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (43 left)
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (42 left)
2019/02/01 17:31:00 [DEBUG] PUT http://127.0.0.1:28934/v1/foo: retrying in 50ms (41 left)
2019/02/01 17:31:00 [DEBUG] POST http://127.0.0.1:43381
2019/02/01 17:31:00 [DEBUG] POST http://127.0.0.1:43381: retrying in 10ms (2 left)
2019/02/01 17:31:00 [DEBUG] POST http://127.0.0.1:43381: retrying in 10ms (1 left)
2019/02/01 17:31:00 [DEBUG] GET http://127.0.0.1:43809/foo/bar
2019/02/01 17:31:00 [DEBUG] GET http://127.0.0.1:34185/foo/bar
--- FAIL: TestClient_ResponseLogHook (0.62s)
    client_test.go:319: expect response callback on 500: "2019/02/01 17:31:01 [DEBUG] GET http://127.0.0.1:40579\n2019/02/01 17:31:01 test_log_pass\n"
2019/02/01 17:31:01 [DEBUG] GET http://127.0.0.1:37651
2019/02/01 17:31:01 [DEBUG] GET http://127.0.0.1:37651: retrying in 1s (4 left)
2019/02/01 17:31:02 [DEBUG] GET http://127.0.0.1:45125
2019/02/01 17:31:02 [DEBUG] HEAD http://127.0.0.1:35293/foo/bar
2019/02/01 17:31:02 [DEBUG] POST http://127.0.0.1:36683/foo/bar
2019/02/01 17:31:02 [DEBUG] POST http://127.0.0.1:41121/foo/bar
FAIL
exit status 1
FAIL	github.com/hashicorp/go-retryablehttp	2.125s

Comment 5 Igor Gnatenko 2019-02-16 17:19:27 UTC
There has been at least one successfull build after mass rebuild.

golang-github-hashicorp-go-retryablehttp-0-0.9.20180612git6e85be8.fc30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1188284


Note You need to log in before you can comment on or make changes to this bug.