Bug 1675026 - golang-github-hashicorp-go-sockaddr: FTBFS in Fedora rawhide/f30
Summary: golang-github-hashicorp-go-sockaddr: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-hashicorp-go-sockaddr
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:35 UTC by Fedora Release Engineering
Modified: 2019-04-26 18:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-26 18:53:27 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
state.log (563 bytes, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:35:21 UTC
golang-github-hashicorp-go-sockaddr failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32395750


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-hashicorp-go-sockaddr at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-hashicorp-go-sockaddr will be orphaned. Before branching of Fedora 31,
golang-github-hashicorp-go-sockaddr will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:35:23 UTC
Created attachment 1530293 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:35:25 UTC
Created attachment 1530294 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:35:26 UTC
Created attachment 1530295 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 12:40:56 UTC
Caused by broken dependencies:
DEBUG util.py:490:  BUILDSTDERR: No matching package to install: 'golang-github-mitchellh-cli-devel-temporary'
DEBUG util.py:490:  BUILDSTDERR: Not all dependencies satisfied
DEBUG util.py:490:  BUILDSTDERR: Error: Some packages could not be found.

Comment 5 Fedora Release Engineering 2019-04-26 18:53:27 UTC
There has been at least one successfull build after mass rebuild.

golang-github-hashicorp-go-sockaddr-1.0.2-1.fc30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1231752


Note You need to log in before you can comment on or make changes to this bug.