Bug 1675033 - golang-github-pkg-errors: FTBFS in Fedora rawhide/f30
Summary: golang-github-pkg-errors: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-pkg-errors
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:35 UTC by Fedora Release Engineering
Modified: 2019-02-18 07:01 UTC (History)
4 users (show)

Fixed In Version: golang-github-pkg-errors-0.8.1-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 07:01:09 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
state.log (773 bytes, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:35:56 UTC
golang-github-pkg-errors failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32396680


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-pkg-errors at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-pkg-errors will be orphaned. Before branching of Fedora 31,
golang-github-pkg-errors will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:35:58 UTC
Created attachment 1530311 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:36:00 UTC
Created attachment 1530312 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:36:01 UTC
Created attachment 1530313 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:12:51 UTC
Caused by tests net being vetable:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
BUILDSTDERR: # github.com/pkg/errors
BUILDSTDERR: vet: ./bench_test.go:26:6: toperr declared but not used
FAIL	github.com/pkg/errors [build failed]


Note You need to log in before you can comment on or make changes to this bug.