Bug 1675037 - golang-github-tchap-go-patricia: FTBFS in Fedora rawhide/f30
Summary: golang-github-tchap-go-patricia: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-tchap-go-patricia
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:36 UTC by Fedora Release Engineering
Modified: 2019-02-13 13:47 UTC (History)
5 users (show)

Fixed In Version: golang-github-tchap-go-patricia-1.0.1-15.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 13:47:01 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
state.log (721 bytes, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:36:19 UTC
golang-github-tchap-go-patricia failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32397224


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-tchap-go-patricia at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-tchap-go-patricia will be orphaned. Before branching of Fedora 31,
golang-github-tchap-go-patricia will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:36:21 UTC
Created attachment 1530323 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:36:23 UTC
Created attachment 1530324 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:36:24 UTC
Created attachment 1530325 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:19:08 UTC
Caused by tests not being vetable:
+ go test -buildmode pie -compiler gc -ldflags ' -extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\''' github.com/tchap/go-patricia/patricia
BUILDSTDERR: # github.com/tchap/go-patricia/patricia
BUILDSTDERR: ../../BUILDROOT/golang-github-tchap-go-patricia-1.0.1-14.fc30.noarch/usr/share/gocode/src/github.com/tchap/go-patricia/patricia/patricia_sparse_test.go:126:12: Errorf call has arguments but no formatting directives
FAIL	github.com/tchap/go-patricia/patricia [build failed]


Note You need to log in before you can comment on or make changes to this bug.