Bug 1675041 - golang-googlecode-google-api-client: FTBFS in Fedora rawhide/f30
Summary: golang-googlecode-google-api-client: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-googlecode-google-api-client
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:36 UTC by Fedora Release Engineering
Modified: 2019-02-14 09:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-14 09:15:35 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
state.log (805 bytes, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:36:44 UTC
golang-googlecode-google-api-client failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32397449


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-googlecode-google-api-client at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-googlecode-google-api-client will be orphaned. Before branching of Fedora 31,
golang-googlecode-google-api-client will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:36:47 UTC
Created attachment 1530335 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:36:49 UTC
Created attachment 1530336 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:36:50 UTC
Created attachment 1530337 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:49:10 UTC
Caused by tests timeout on s390x:
...very long sniped ommitted...
google.golang.org/api/support/bundler.(*Bundler).startFlushLocked.func1(0xc0000c6180, 0x2aa3ca28cc0, 0xc032a314c0, 0x97, 0x5, 0xbdc30)
	/builddir/build/BUILD/google-api-go-client-511bab8e55decfbe784cd2d1868fa5cda62dc6c1/_build/src/google.golang.org/api/support/bundler/bundler.go:271 +0x7a
created by google.golang.org/api/support/bundler.(*Bundler).startFlushLocked
	/builddir/build/BUILD/google-api-go-client-511bab8e55decfbe784cd2d1868fa5cda62dc6c1/_build/src/google.golang.org/api/support/bundler/bundler.go:266 +0x128
goroutine 836649 [sync.Cond.Wait]:
runtime.goparkunlock(...)
	/usr/lib/golang/src/runtime/proc.go:307
sync.runtime_notifyListWait(0xc000060110, 0x1c8d5fe00114f20)
	/usr/lib/golang/src/runtime/sema.go:510 +0x11e
sync.(*Cond).Wait(0xc000060100)
	/usr/lib/golang/src/sync/cond.go:56 +0xd0
*** Test killed: ran too long (10m0s).
signal: killed
FAIL	google.golang.org/api/support/bundler	615.540s

Comment 5 Igor Gnatenko 2019-02-14 09:15:35 UTC
There has been at least one successfull build after mass rebuild.

golang-googlecode-google-api-client-0-0.29.20181027git511bab8.fc30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1188629


Note You need to log in before you can comment on or make changes to this bug.