Bug 167524 - XFree86-4.3.0-55 fails to build cleanly from SRPM with gcc-4.0.1-4.fc4
XFree86-4.3.0-55 fails to build cleanly from SRPM with gcc-4.0.1-4.fc4
Status: CLOSED WONTFIX
Product: Fedora Legacy
Classification: Retired
Component: XFree86 (Show other bugs)
fc1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-03 21:50 EDT by Sivasankar Chander
Modified: 2007-04-18 13:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 01:13:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow XFree86-4.3.0 to build cleanly with gcc-4.0.1 (1.43 KB, patch)
2005-09-03 21:50 EDT, Sivasankar Chander
no flags Details | Diff

  None (edit)
Description Sivasankar Chander 2005-09-03 21:50:45 EDT
Description of problem: XFree86-4.3.0-55 fails to build from SRPM using
(upgraded) gcc-4.0.1 from Fedora Core 4 Updates


Version-Release number of selected component (if applicable):
XFree86-4.3.0-55.src.rpm


How reproducible: Always


Steps to Reproduce:
1. Upgrade to gcc-4.0.1-4.fc4 (resolving any additional dependencies)
2. Rebuild XFree86-4.3.0-55.src.rpm

  
Actual results: The build fails with the relevant errors below:

...
tdfx_span.c: In function 'tdfxDDWriteDepthPixels':
tdfx_span.c:976: error: invalid lvalue in assignment
tdfx_span.c:1008: error: invalid lvalue in assignment
tdfx_span.c: In function 'write_stencil_pixels':
tdfx_span.c:1242: error: invalid lvalue in assignment
...


Expected results:


Additional info: The attached patch (adapted from a Debian
patch for the same issue) allows a clean build of XFree86-4.3.0
with gcc-4.0.1. This is a slightly truncated version of the
patch included in:

http://lists.debian.org/debian-x/2005/06/msg00318.html
Comment 1 Sivasankar Chander 2005-09-03 21:50:46 EDT
Created attachment 118432 [details]
Patch to allow XFree86-4.3.0 to build cleanly with gcc-4.0.1
Comment 2 Pekka Savola 2005-09-04 01:13:50 EDT
Fedora Legacy only has resources for security fixes, and supporting gcc version
which wasn't shipped with FC1 doesn't seem to be one, so closing.

Note You need to log in before you can comment on or make changes to this bug.