Bug 167579 - Installing supertux 0.1.3-1.fc4 creates two .desktop files in /usr/share/applications/
Installing supertux 0.1.3-1.fc4 creates two .desktop files in /usr/share/appl...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-05 16:54 EDT by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 12:27:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gordon 2005-09-05 16:54:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.5

Description of problem:
I recently installed SuperTux from Extras (`yum install supertux`). However, it created two entries in my Gnome Games menu. This is because it creates two .desktop files in /usr/share/applications: "supertux.desktop" and "fedora-supertux.desktop". I can confirm this because `yum provides` says that they both are provided by supertux.i386 (version 0.1.3-1.fc4) They are essentially the same thing (both use the SuperTux icon and run 'supertux'). However, "supertux.desktop" seems to be more complete, as it contains translated descriptions. Simply removing "fedora-supertux.desktop" seems to fix this.

Version-Release number of selected component (if applicable):
supertux-0.1.3-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Run `yum -y install supertux` as root.
2.
3.
  

Actual Results:  Two menu entries were added.

Expected Results:  Only one menu entry is needed.

Additional info:
Comment 1 Panu Matilainen 2005-09-06 01:37:12 EDT
Steve, please update the owners.list in CVS to make you the owner of supertux, I
*think* that'll also change the default owner in bugzilla?
Comment 2 Steven Pritchard 2005-09-06 12:27:25 EDT
A fix for this is in the build system now.
Comment 3 Peter Gordon 2005-09-06 17:47:07 EDT
Good to hear. Thanks very much. :)

Note You need to log in before you can comment on or make changes to this bug.