Bug 16758 - /etc/X11/xdm/Xsession #!/bin/sh --> #!/bin/bash (?)
Summary: /etc/X11/xdm/Xsession #!/bin/sh --> #!/bin/bash (?)
Status: CLOSED DUPLICATE of bug 16648
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-22 21:56 UTC by Bowe Strickland
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 21:56:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bowe Strickland 2000-08-22 21:56:18 UTC
when performing a minimal X install (only the @ X Window System component),
root
cannot login via xdm.  the dump of ~root/.xsession-errors:

~root/.xsession-errors:
>> /etc/X11/xdm/Xsession: xsetroot: command not found
>> /etc/X11/xdm/Xsession: xrdb: command not found
>> /etc/X11/xdm/Xsession: xmodmap: command not found
>>  WARNING: You selected Fvwm2 as your window manager, but your
installation
>>  does not appear to be functional. The executable /usr/X11R6/bin/fvwm2
was 
>>  not found on your system.
>> RESUMING with TWM...
>> /usr/X11R6/bin/RunWM: xterm: command not found

proposed fix... change first line of /etc/X11/xdm/Xsesion from 

#!/bin/sh

to 

#!/bin/bash --login

it worked for me, though i haven't thought through all of the implications.
perhaps 
#!/bin/bash is sufficient...

--bowe

Comment 1 Glen Foster 2000-08-23 13:51:20 UTC

*** This bug has been marked as a duplicate of 16648 ***


Note You need to log in before you can comment on or make changes to this bug.