Bug 167583 - kernel upgrade 2.6.12-1.1447_FC4 kills IPW2200 Wireless
Summary: kernel upgrade 2.6.12-1.1447_FC4 kills IPW2200 Wireless
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-05 22:35 UTC by guy berges
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 16:04:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description guy berges 2005-09-05 22:35:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Using YUM, I upgraded from 2.6.12-1.1398 to 2.6.12-1.1447.  After rebooting to the new kernel the network utility could not find eth1 (my ipw2200 wireless card).  iwconfig found no wireless devices.  ifconfig couldn't find eth1.  Rebooted to 2.6.2.12-1.1398 and everything was there......

Version-Release number of selected component (if applicable):
kernel 2.6.12-1.1447

How reproducible:
Always

Steps to Reproduce:
1. Use YUM upgrade to kernel 2.6.12-1.1447
2. Reboot
3. call iwconfig
  

Actual Results:  no wirless devices found

Expected Results:  should find eth1 (ipw2200 wireless card)

Additional info:

Comment 1 Dave Jones 2005-09-26 06:37:11 UTC
this driver hasn't changed, so this has to be something unrelated.
Is it still a problem with the latest kernel errata ?

If so, can you paste the dmesg output ?


Comment 2 guy berges 2005-09-27 02:35:45 UTC
Okay, I just used YUM Extender to upgrade to kernel 2.6.12-1.1456_FC4.  As
reported before, when booting to this kernel there is no sign of recognition of
my ipw2200 network card.  I upgraded the kernel package and the kernel
development package.  I was very careful to only upgrade those two packages.

Here are the log outputs that I could find:

[root@localhost ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.


[root@localhost ~]# ifconfig eth1
eth1: error fetching interface information: Device not found

[root@localhost log]# tail -25 dmesg
NET: Registered protocol family 10
Disabled Privacy Extensions on device c03e6a40(lo)
IPv6 over IPv4 tunneling driver
ACPI: AC Adapter [AC] (on-line)
Using generic hotkey driver
ACPI: Battery Slot [BAT0] (battery present)
ACPI: Battery Slot [BAT1] (battery absent)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: Using generic hotkey driver
toshiba_acpi: Using generic hotkey driver
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on dm-0, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: initialized (dev hda1, type ext3), uses xattr
SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
Adding 2031608k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts


Comment 3 Bill Nottingham 2005-09-28 00:08:53 UTC
What happens if you manually load the driver?

Comment 4 guy berges 2005-09-28 00:29:19 UTC
I have the following kernels on this box:
     2.6.12-1.1369
             .1390
             .1398

The .1369 is the kernel that came with the version of Fedora Core 4 that I
created ISO for.  For the others I have used YUM to update the kernel and they
have always located and recognized my IPW2200 card.

Using the same process I have upgraded my kernel to .1447 and .1456 and both of
those kernels report no wireless capability, i.e. they don't recognize the IPW
card.  They give the results listed above.  Rebooting to any of the .13XX
kernels gives back wireless capability.

Having said that, and admitting that I'm still pretty much a linux newbie, do I
understand Bill Nottingham request: He wants me to upgrade the kernel and then
reload the IPW driver.  Is this correct?

Comment 5 Bill Nottingham 2005-09-28 00:36:57 UTC
Please post the output of 'lsmod'; if ipw2200 is not listed there, please run,
as root, 'modprobe ipw2200', and post the output of 'dmesg'.

Comment 6 guy berges 2005-09-28 03:26:49 UTC
booting to the .1456 kernel.  See requested listings below

[root@localhost ~]# lsmod
Module                  Size  Used by
nls_utf8                2241  1
parport_pc             29189  1
lp                     13129  0
parport                40969  2 parport_pc,lp
autofs4                29637  2
rfcomm                 42589  0
l2cap                  30917  5 rfcomm
bluetooth              56517  4 rfcomm,l2cap
sunrpc                168453  1
pcmcia                 29153  4
video                  16069  0
button                  4161  0
battery                 9541  0
ac                      4933  0
md5                     4161  1
ipv6                  268737  10
ohci1394               41609  0
ieee1394              305081  1 ohci1394
yenta_socket           21833  2
rsrc_nonstatic         12993  1 yenta_socket
pcmcia_core            51293  3 pcmcia,yenta_socket,rsrc_nonstatic
uhci_hcd               35281  0
ehci_hcd               41165  0
shpchp                 94661  0
i2c_i801                8909  0
i2c_core               21825  1 i2c_i801
snd_intel8x0m          19845  0
snd_intel8x0           34945  1
snd_ac97_codec         76217  2 snd_intel8x0m,snd_intel8x0
snd_seq_dummy           3781  0
snd_seq_oss            37569  0
snd_seq_midi_event      9409  1 snd_seq_oss
snd_seq                62801  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9037  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            51569  0
snd_mixer_oss          18113  2 snd_pcm_oss
snd_pcm               100553  4
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              33733  2 snd_seq,snd_pcm
snd                    57669  10
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11169  2 snd
snd_page_alloc          9925  3 snd_intel8x0m,snd_intel8x0,snd_pcm
ipw2200                75084  0
ieee80211              23237  1 ipw2200
ieee80211_crypt         7749  1 ieee80211
tg3                   113477  0
dm_snapshot            17413  0
dm_zero                 2113  0
dm_mirror              26157  0
ext3                  132681  2
jbd                    86233  1 ext3
dm_mod                 58101  6 dm_snapshot,dm_zero,dm_mirror

ran "modprobe ipw2200"  No detectable delay in the return of the command line
prompt.  dmesg below:

[root@localhost log]# tail -60 dmesg
ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] -> GSI 9 (level, low) -> IRQ 9
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
usb 1-4: new high speed USB device using ehci_hcd and address 2
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 9, io base 0x0000ec00
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
Linux Kernel Card Services
  options:  [pci] [cardbus] [pm]
PCI: Enabling device 0000:02:01.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:02:01.0[A] -> Link [LNKB] -> GSI 4 (level, low) -> IRQ 4
Yenta: CardBus bridge found at 0000:02:01.0 [1043:1864]
Yenta: ISA IRQ mask 0x0008, PCI irq 4
Socket status: 30000006
ACPI: PCI Interrupt 0000:02:01.1[B] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
Yenta: CardBus bridge found at 0000:02:01.1 [1043:1864]
Yenta: ISA IRQ mask 0x0008, PCI irq 11
Socket status: 30000006
hub 1-4:1.0: USB hub found
hub 1-4:1.0: 4 ports detected
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1250 $ Ben Collins <bcollins@debian.org>
ACPI: PCI Interrupt 0000:02:01.2[C] -> Link [LNKC] -> GSI 9 (level, low) -> IRQ 9
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[9]  MMIO=[ff9ef800-ff9effff]  Max
Packet=[2048]
usb 1-4.1: new full speed USB device using ehci_hcd and address 3
hub 1-4.1:1.0: USB hub found
hub 1-4.1:1.0: 3 ports detected
usb 1-4.1.1: new low speed USB device using ehci_hcd and address 4
input: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.7-4.1.1
usb 1-4.1.3: new full speed USB device using ehci_hcd and address 5
input: USB HID v1.10 Keyboard [ORTEK USB Keyboard Hub] on
usb-0000:00:1d.7-4.1.3input: USB HID v1.10 Device [ORTEK USB Keyboard Hub] on
usb-0000:00:1d.7-4.1.3
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00e01800031a8e06]
SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts
NET: Registered protocol family 10
Disabled Privacy Extensions on device c03e6a40(lo)
IPv6 over IPv4 tunneling driver
ACPI: AC Adapter [AC] (on-line)
Using generic hotkey driver
ACPI: Battery Slot [BAT0] (battery present)
ACPI: Battery Slot [BAT1] (battery absent)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: Using generic hotkey driver
toshiba_acpi: Using generic hotkey driver
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on dm-0, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: initialized (dev hda1, type ext3), uses xattr
SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
Adding 2031608k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts


Comment 7 Bill Nottingham 2005-09-28 03:53:48 UTC
Is that the output of the 'dmesg' command, or /var/log/dmesg? They're two
different things.

Comment 8 guy berges 2005-09-28 14:13:20 UTC
This is the output of /var/log/dmesg.

Do I just type "dmesg" at the command prompt logged in as "root" to get the 
other?

Comment 9 Bill Nottingham 2005-09-28 17:00:43 UTC
Yes.

Comment 10 guy berges 2005-09-29 01:04:48 UTC
Here is the pertinent part.  If you want it all, ask and I'll insert it.

ieee80211_crypt: registered algorithm 'NULL'
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI Interrupt 0000:02:02.0[A] -> Link [LNKB] -> GSI 4 (level, low) -> IRQ 4
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.2-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: 0xFFFFFFFE

Do I need new firmware or did we break something??????

Comment 11 Bill Nottingham 2005-09-29 01:13:53 UTC
1.0.0 requires version 2.2 of the firmware, available from:

http://ipw2200.sourceforge.net/firmware.php?fid=4


Do you have ipw-2.2-boot.fw in /lib/firmware?

Comment 12 guy berges 2005-09-29 02:07:36 UTC
No!  I have ipw-2.3-boot.fw in /lib/firmware.

Please remember that my ipw2200 card is working now as I type this.  I am now
booted to a .13XX kernel (.1396 I think).

Comment 13 guy berges 2005-09-29 02:26:58 UTC
The plot thickens.

I have both 2.2 and 2.3 firmware.  I reset to the 2.2 firmware and the .1456
kernel recognizes my ipw2200 card.  However, wpasupplicant doesn't work.  When I
use the 2.3 firmware wpasupplicant works but the .1447 and .1456 kernels don't
recognize the ipw2200 card.

I must have wpasupplicant so I'll stick with the .1398 kernel while the conflict
is resolved.

Comment 14 Bill Nottingham 2005-09-29 03:40:59 UTC
OK, so, under .1398, run:

/sbin/modinfo ipw2200 | grep 'version:'

I suspect that the version there is 1.0.4. In the .13xx series, we included
ipw2200 as a separate patch to the main kernel, and that was the version we had.

That version requires the 2.3 version of the firmware.

In later (.14xx, not sure when the exact switch was) a version of the ipw2200
driver was merged upstream, so that's what we started using. That version was
the earlier 1.0.0 version, which uses version 2.2 of the firmware.

I suspect that WPA was fixed between 1.0.0 and 1.0.4, but ICBW.

So, you might as well just leave both versions of the firmware in /lib (they can
coexist fine there), and I'd suspect the driver will be updated at some point
int the future. Dave?

Comment 15 Dave Jones 2005-09-29 05:09:59 UTC
We had a later revision of these drivers up until 1358, which was before FC4 got
released. I reverted back to rev 1.0.0 for the release, where they've stayed since.

The driver on 1398 and 14xx should be exactly the same.

Rawhide has them dropped completely in favour of what went upstream, but that's
a different story to whats going here in FC4.

We can't uprev the driver in FC4, as it causes great mess due to multiple
drivers sharing the ieee80211 layer, and all of them seem to want to run with a
different revision of it.

Given its now been moved upstream, I'm hopeful that all these issues will just
fall out when we eventually rebase FC4 to 2.6.14


Comment 16 guy berges 2005-09-30 03:05:35 UTC
/sbin/modinfo yields 1.0.6

With the 2.2 firmware both 1398 and 1456 recognize the ipw board.  The problem
is that then wpa won't work.

Is the expectation that this aparent conflict will be resolved by rebasing FC4
to 2.6.14?

Comment 17 Dave Jones 2005-09-30 04:58:52 UTC
eh? The highest rev ever included in Fedora was 1.0.4 according to the cvs log.

Did you build this yourself ?


Comment 18 guy berges 2005-10-01 03:18:58 UTC
No, FC4 is standard.  I did go and get firmware and driver when I first lit off
the wireless.  I think I went elsewhere and got another firmware and driver when
I was trying to get WPA to work.

Comment 19 Dave Jones 2005-10-01 03:51:39 UTC
I just double checked, those two kernels were definitly both 1.0.0

$ modinfo
/lib/modules/2.6.12-1.1398_FC4/kernel/drivers/net/wireless/ipw2200/ipw2200.ko  |
grep version
version:        1.0.0

$ modinfo
/lib/modules/2.6.12-1.1456_FC4/kernel/drivers/net/wireless/ipw2200/ipw2200.ko 
|grep version
version:        1.0.0


It's unlikely that we'll rebase it to a later version in FC4.
What will happen however is that eventually, we'll see a 2.6.14 backport to FC4
after its release. That has an integrated set of ipw drivers. (Which should
answer your question in comment #16)

Comment 20 guy berges 2005-10-01 03:56:06 UTC
I guess my only question, after all of this, is this: I need the 2.2 firmware to
load the 14XX kernel and the 2.3 firmware to run wpasupplicant.  Seeing as I
can't have two firmware versions loaded at the same time what resolves the conflict?

Comment 21 Bill Nottingham 2005-10-03 18:55:45 UTC
I don't doubt what you're saying, but if you're using the 2.3 version of the
firmware, you're not using version 1.0 of the driver - did you compile the
driver yourself at some point?

The best way to get out of the conflict you see is to use the later driver on
the current kernel, which would require patching it in from upstream or building
it out of tree.

Comment 22 Dave Jones 2005-11-10 19:54:21 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.


Comment 23 guy berges 2005-11-11 20:14:00 UTC
Kernel 2.6.14-1.1637 will not associate with my wpa access point.

Comment 24 John W. Linville 2005-12-02 19:17:33 UTC
The Fedora-netdev kernels are available from here: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give those a try and post the results here...thanks! 

Comment 25 guy berges 2005-12-03 20:25:28 UTC
Installed fc5-netdev-4.  Failed to find my IPW2200 card.  Installed firmware
2.4.  Now boots nicely.  Fails to associate with my wpa access point.

This appears to be either a disconnect between the version of firmware that the
kernel wants and the one that wpa_supplicant wants.  If not that then there is
some reconfiguration of wpa_supplicant needed that I haven't found yet.

Comment 26 guy berges 2005-12-03 20:49:02 UTC
Okay, as in "Whew"!  This problem was a disconnect between wpa_supplicant and
the new kernels.  I updated wpa_supplicant from latest stable 0.3.9 to new
stable 0.4.7.  All works correctly now.  Thanks with your patience with this
newbie.....

Comment 27 John W. Linville 2005-12-05 16:04:00 UTC
It sounds like this is all set to filter-in to Fedora over time.  Until then, 
I'm happy to have you as a Fedora-netdev user! 
 
I'm going to close this as UPSTREAM...thanks! 


Note You need to log in before you can comment on or make changes to this bug.