Bug 167586 - Anaconda errs out with more than fifteen partition on /dev/sda
Anaconda errs out with more than fifteen partition on /dev/sda
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-05 19:35 EDT by Terje
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 11:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje 2005-09-05 19:35:46 EDT
From Bugzilla Helper:
User-Agent: Opera/8.02 (Windows NT 5.1; U; en)

Description of problem:
Bug occurs in both graphical and text install environment.

When preconfiguring partitions in partitionmagic (or any partitioner that is 
able to handle more than 15 partitions on a device) and installing fedora to a 
partition that should be availible (in my case 13 and 14) the installation errs 
out.

The problem is based on a limitation of the /dev implementation, but since no 
data is written or accessed on /dev/hda16+ then the installation should be able 
to continue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD
2. Choose graphical or text login
3. Choose workstation setup
* Error * Error mounting filesystem on /dev/sda16: No such file or address.
4. Manually partition with DiskDruid
5. Choose /boot to /dev/sda13 and / to /dev/sda14 (pre setup with partition 
magic in Windows)
6. Bootloader on /dev/sda1 (Grub)
7. DHCP for network address
8. No firewall
9. Selinux disabled
10. Timezone Europe/Oslo
11. Use default package selection
12. Check that you've got disc 1 and 2 (press continue)
* Error * Error informing the kernel about modifications to partition /dev/hda16 
- Invalid argument....
* Error * Error informing the kernel about modifications to partition /dev/hda17 
- Invalid argument....
* Error * Error informing the kernel about modifications to partition /dev/hda18 
- Invalid argument....

Exception Occured

An unhandled exception occured. This is most likely a bug...

It goes on to ask me to include the traceback info, but I guess you can 
reproduce it yourself and write it down because my hand has already cramped. You 
could atleast put GMP on the text consoles to help with this. :/

Actual Results:  Was given the option to debug or continue. When continuing I get a friendly 
message telling me I can reboot my computer.

Expected Results:  Packages should start copying right about this stage, shouldn't they?

Additional info:
Comment 1 Jeremy Katz 2005-09-06 11:23:54 EDT
There's really not a good way to handle more than 15 partitions on a scsi disk
with the way the kernel handles things.

Note You need to log in before you can comment on or make changes to this bug.