Bug 1676288 - mlton: FTBFS in Fedora rawhide/f30
Summary: mlton: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mlton
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Goode
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1704279
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 22:30 UTC by Fedora Release Engineering
Modified: 2019-08-08 16:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-08 16:54:17 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 22:30:19 UTC
mlton failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32576200


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix mlton at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
mlton will be orphaned. Before branching of Fedora 31,
mlton will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 22:30:22 UTC
Created attachment 1533796 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 22:30:23 UTC
Created attachment 1533797 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 22:30:24 UTC
Created attachment 1533798 [details]
state.log

Comment 4 Fedora Release Engineering 2019-04-26 23:34:32 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 5 Adam Goode 2019-04-27 15:39:36 UTC
ppc64le is broken during compile:
BUILDSTDERR: make[2]: *** [Makefile:128: mlton-compile] Segmentation fault (core dumped)

Comment 6 Adam Goode 2019-04-27 16:00:36 UTC
Oh no this is also broken on f29:
BUILDSTDERR: make[2]: *** [Makefile:128: mlton-compile] Segmentation fault (core dumped)

Comment 7 Adam Goode 2019-04-28 16:01:11 UTC
I regenerated the bootstrap sources after finding a possible bug. It worked in a scratch build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=34503566

But fails in non-scratch
https://koji.fedoraproject.org/koji/buildinfo?buildID=1259638
https://koji.fedoraproject.org/koji/buildinfo?buildID=1259637
https://koji.fedoraproject.org/koji/buildinfo?buildID=1259639
https://koji.fedoraproject.org/koji/buildinfo?buildID=1259640


I am trying a local build (very slow) now. I might just have to disable ppc64 for now,

Comment 8 Adam Goode 2019-04-28 23:51:53 UTC
The bootstrap sources were probably fine. The issue seems to be that mlton binaries run on POWER8 will segfault, but work properly on POWER9. The scratch builds seem consistently to run on POWER9 and succeed, the non-scratch builds on POWER8 and fail.

This is reproducible with qemu as well.

Comment 9 Fedora Release Engineering 2019-08-08 16:54:17 UTC
The following builds were made: mlton-20180207-12.fc31


Note You need to log in before you can comment on or make changes to this bug.