Bug 167633 - wrongly claims "file has been manually modified"
wrongly claims "file has been manually modified"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-httpd (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-06 10:21 EDT by Dimitri Papadopoulos
Modified: 2015-03-04 20:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 12:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot - initial s-c-httpd window (18.82 KB, image/png)
2005-09-06 10:23 EDT, Dimitri Papadopoulos
no flags Details
screenshot - s-c-httpd window with modifications (19.91 KB, image/png)
2005-09-06 10:23 EDT, Dimitri Papadopoulos
no flags Details
screenshot - a dialog pops up when attempting to save (21.81 KB, image/png)
2005-09-06 10:24 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2005-09-06 10:21:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
When trying to save the modifications to the Apache server configuration, a dialog pops up with the following error message:
The configuration file has been manually modified. Overwrite?

It can't have been manually modified because this is a pristine Apache installation. To make sure I erased and reinstalled the following packages:
	mod_ssl
	mod_dav_svn
	httpd_suexec
	httpd
	system-config-httpd
I also deleted /etc/httpd between erasing and reinstalling.

I have even deleted the following files in an attempt to shut up s-c-httpd:
	/etc/alchemist/namespace/system-config-httpd/local.adl
	/var/cache/alchemist/apache/*

Whatever I do system-config-httpd claims the configuration has been manually modified.


Version-Release number of selected component (if applicable):
system-config-httpd-1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e mod_ssl mod_dav_svn httpd_suexec httpd system-config-httpd
2. rm -r /etc/httpd
3. rm /etc/alchemist/namespace/system-config-httpd/local.adl
4. rm /var/cache/alchemist/apache/*
5. up2date -i mod_ssl mod_dav_svn httpd_suexec httpd system-config-httpd
6. system-config-httpd
7. Modify "Server Name" and "Webmaster email address"
8. Click the OK button.


Actual Results:  A dialog pops up claiming the configuration file has been manually modified.


Expected Results:  The configuration should have been silently saved.


Additional info:
Comment 1 Dimitri Papadopoulos 2005-09-06 10:23:03 EDT
Created attachment 118506 [details]
screenshot - initial s-c-httpd window
Comment 2 Dimitri Papadopoulos 2005-09-06 10:23:51 EDT
Created attachment 118507 [details]
screenshot - s-c-httpd window with modifications
Comment 3 Dimitri Papadopoulos 2005-09-06 10:24:46 EDT
Created attachment 118508 [details]
screenshot - a dialog pops up when attempting to save
Comment 5 Phil Knirsch 2005-10-10 09:42:47 EDT
The problem comes from the fact that the httpd config file has never been edited
before with s-c-httpd. During the inital save check it doesn't find any backup
files resp. checksums for previous files and therefore assumes that this is
modified.

In terms of s-c-httpd view of the world this is partially correct as the
httpd.conf file it will write will certainly be different than the one from a
pristine installation of httpd.

I agree though that this message can be misleading in this case, so i'll be
makeing a patch for it. This bugfix is not yet committed for inclusion in an
Update release though.

Read ya, Phil
Comment 8 Phil Knirsch 2008-08-18 12:23:03 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.