Bug 167643 - system-config-lvm unusable with lvm2-cluster installed but without cluster membership
Summary: system-config-lvm unusable with lvm2-cluster installed but without cluster me...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-06 15:51 UTC by Nate Straz
Modified: 2009-04-16 23:11 UTC (History)
1 user (show)

Fixed In Version: RHEL-4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 02:09:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nate Straz 2005-09-06 15:51:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When lvm2-cluster is installed I get this error when trying to initialize a partition.

pvcreate command failed. Command attempted: "/usr/sbin/pvcreate -M 2 /dev/sdb1" - System Error Message:   connect() failed on local socket: Connection refused
  Locking type 2 initialisation failed.

I think the --ignorelockingfailure is needed for this to work properly.

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.3-1.0

How reproducible:
Always

Steps to Reproduce:
1. Install lvm2-cluster
2. Launch system-config-lvm
3. Try to initialize an entity
  

Actual Results:  Got the error message above.

Expected Results:  The partition should have become a physical volume.

Additional info:

Comment 1 Nate Straz 2005-09-06 16:08:44 UTC
It turns out that just about any time the GUI tries to get LVM information it
needs the --ignorelockingfailure flag.  So if you have the GUI running and you
can see PVs or LVs, then you install lvm2-cluster
(lvm2-cluster-2.01.14-1.0.RHEL4 in this case) and do View->Reload, everything
will go back to Uninitialized Entities.

Comment 2 Stanko Kupcevic 2005-09-07 15:20:55 UTC
cLVM support in s-c-lvm is scheduled for RHEL4U3 (see bz159455). 

Fix, until then, would amount to simple pop-up saying that clustered LVM is not
yet implemented, when cLVM configuration is detected.


Comment 5 Stanko Kupcevic 2005-09-08 22:55:46 UTC
Fixed in 1.0.4

Comment 7 Nate Straz 2005-09-15 20:59:10 UTC
Verified in 1.0.5-1.0.

Comment 8 David Lawrence 2006-07-18 02:41:12 UTC
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Comment 9 Ben Levenson 2008-02-19 02:09:31 UTC
this should have been released in RHEL-4.2


Note You need to log in before you can comment on or make changes to this bug.