Bug 167664 - unhandled exception from failed vgcreate on new disk
unhandled exception from failed vgcreate on new disk
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-06 15:15 EDT by Doug Chapman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 11:01:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file (614.64 KB, text/plain)
2005-09-06 17:52 EDT, Doug Chapman
no flags Details

  None (edit)
Description Doug Chapman 2005-09-06 15:15:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
This exception is seen on an HP rx2600 when installing to a new disk or a disk that has had all partitions removed prior to installation.

The install is being done via NFS to qafiler:/vol/vol1/redhat/nightly/RHEL4-U2-re0905.nightly/ia64/ia64-AS

              | An unhandled exception has occurred.  This     # |
              | is most likely a bug.  Please copy the full    # |
              | text of this exception and file a detailed     # |
              | bug report against anaconda at                 # |
              | http://bugzilla.redhat.com/bugzilla/           # |
              |                                                # |
              | Traceback (most recent call last):             # |
              |   File "/usr/bin/anaconda", line 1173, in ?    # |
              |     intf.run(id, dispatch, configFileData)     # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/text.py", line 510, in run            # |
              |     dispatch.gotoNext()                        # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/dispatch.py", line 171, in gotoNext   # |
              |     self.moveStep()                            # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/dispatch.py", line 239, in moveStep   # |
              |     rc = apply(func, self.bindArgs(args))      # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/packages.py", line 570, in            # |
              | turnOnFilesystems                              # |
              |     thefsset.createLogicalVolumes(instPath)    # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/fsset.py", line 1431, in              # |
              | createLogicalVolumes                           # |
              |     entry.device.setupDevice(chroot)           # |
              |   File                                         # |
              | "/usr/src/build/603037-ia64/install//usr/lib/  # |
              | anaconda/fsset.py", line 2012, in setupDevice  # |
              |     raise SystemError, "vgcreate failed for    # |
              | %s" %(self.name,)                              # |
              | SystemError: vgcreate failed for VolGroup00    # |



Version-Release number of selected component (if applicable):
RHEL4-U2-re0905.nightly

How reproducible:
Always

Steps to Reproduce:
1. remove all partitions on a disk
2. start install, select "reinstall system" if asked
3. when prompted for disks to use select _only_ the disk you removed partitions from (simulates a customer installing on a new disk)
4. allow anaconda to parition automatically, take the defaults
5. after answering all questions and anaconda actually tries to partition the disk it will fail with the description shown above
  

Additional info:
Comment 1 Jeremy Katz 2005-09-06 16:47:10 EDT
Can you provide the complete traceback you received?  And note that this very
much isn't the same as "new disk" due to some fun with how LVM works.
Comment 2 Doug Chapman 2005-09-06 17:17:28 EDT
This was the complete traceback however I will past a better formatted version
below.  Also, yes it may not be exactly the same as a new disk but I first hit
this with a brand new disk (straight out of the box) but I came up with this as
an easy reproducer without needing to install a fresh disk.

Here is the better formatted traceback:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1173, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/text.py", line 510,
in run
    dispatch.gotoNext()
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/dispatch.py", line
171, in gotoNext
    self.moveStep()
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/packages.py", line
570, in turnOnFilesystems
    thefsset.createLogicalVolumes(instPath)
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/fsset.py", line
1431, in createLogicalVolumes
    entry.device.setupDevice(chroot)
  File "/usr/src/build/603037-ia64/install//usr/lib/anaconda/fsset.py", line
2012, in setupDevice
    raise SystemError, "vgcreate failed for %s" %(self.name,)
SystemError: vgcreate failed for VolGroup00

> /usr/src/build/603037-ia64/install/usr/lib/anaconda/fsset.py(2012)setupDevice()
-> raise SystemError, "vgcreate failed for %s" %(self.name,)
(Pdb)
Comment 3 Jeremy Katz 2005-09-06 17:29:19 EDT
That's only the portion we show, the full traceback contains *much* more data.

Since you're on an rx2600 and don't have a floppy, there are a few ways to get
the full traceback:
a) USB floppy drive
b) Switch to tty2 (if on the console) to scp it off (/tmp/anacdump.txt)
c) Hit ctrl-z if doing a serial install to get a shell and scp it off
Comment 4 Doug Chapman 2005-09-06 17:52:02 EDT
Created attachment 118534 [details]
anaconda dump file
Comment 5 Doug Chapman 2005-09-06 17:53:05 EDT
Thanks for the tip on getting more info out of this.  If you have not guessed I
am new to this.  I am the HP on-site partner (i.e. I actually work for HP but I
have an office here in Westford).

I am attaching the anacdump.txt file.

Note You need to log in before you can comment on or make changes to this bug.