Bug 167698 - system clock speeds up on load
system clock speeds up on load
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 07:10 EDT by Noa Resare
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.12-1.1456_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (18.60 KB, text/plain)
2005-09-07 07:10 EDT, Noa Resare
no flags Details

  None (edit)
Description Noa Resare 2005-09-07 07:10:48 EDT
Description of problem:

The system clock on my new machine seems seriously broken, running about 20 
minutes or so too fast per 24 hour period. It doesn't seem to matter which fc4
kernel I use. It runs too fast for ntp to keep up, so it bails after a while.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1447_FC4

How reproducible:
always

Steps to Reproduce:
1. boot
2. sync time with ntpdate
3. wait and compare
  
Actual results:
24 hours after sync: ons sep  7 13:27:49 CEST 2005
date on ntp synced reference box: Wed Sep  7 13:11:00 CEST 2005

Expected results:


Additional info:
attaching dmesg with hardware info
Comment 1 Noa Resare 2005-09-07 07:10:48 EDT
Created attachment 118548 [details]
dmesg
Comment 2 Noa Resare 2005-09-23 04:28:58 EDT
Preliminary tests with kernel-smp-2.6.12-1.1456_FC4 indicates that this problem
has been solved. Thanks!
Comment 3 Noa Resare 2005-10-18 06:50:51 EDT
Since my wonderful corporate network admins firewalled off the ntp port this
problem resurfaced. 

However, some preliminary testing shows that passing the no_timer_check=0 option
to the kernel at boot time works around the problem.

I leave this one as closed since the problems can be worked around, but
obviously it isn't really fixed so if any of the kernel wizards wants to take a
look at it I'm more than willing to test patches etc.
Comment 4 Noa Resare 2005-10-20 11:03:50 EDT
Finally I see the pattern. The system clock speeds up when the system load goes
up. One testcase written in java that accesses a local oracle database seems to
trigger this behaviour extremely efficiently. Test takes about 5 seconds wall
clock time, but ~10 seconds system clock time due to the speedup.

The problem goes away when noapic is specified at boot time.

The problem also goes away when I boot the vanilla 2.6.13.4 kernel from
kernel.org (with standard config).
Comment 5 Dave Jones 2005-11-10 16:56:25 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 6 Dave Jones 2006-02-03 02:29:41 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 7 John Thacker 2006-05-04 21:30:42 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.