Bug 167699 - Corrupted BDFs generated when using fstobdf on a X.org xfs
Corrupted BDFs generated when using fstobdf on a X.org xfs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-09-07 07:11 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0072
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:16:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 4381 None None None Never

  None (edit)
Description Bastien Nocera 2005-09-07 07:11:30 EDT
The original Xfree86 bug was fixed:
http://bugzilla.xfree.org/show_bug.cgi?id=93

But the problem still occurs with X.org's fstobdf.
Filed with X.org as 4381.
Comment 1 Mike A. Harris 2005-09-12 12:00:15 EDT
Thanks Bastien.  I've reviewed the upstream bug report you posted, the
source code, and the patch attached to the upstream bug report.

The patch seems low-risk, and is used in later XFree86 releases.  I think
it is reasonable to include this patch in Fedora development and get it
tested, then assuming no regressions or other problems occur, 
when development begins on RHEL4U3 we can consider including this in
the update also.

Thanks again.
Comment 5 Mike A. Harris 2005-11-29 03:26:30 EST
Fixed in xorg-x11-6.8.2-1.EL.13.21

Setting status to "MODIFIED".  Please test and report back success or failure.
Comment 6 Mike A. Harris 2005-11-29 05:52:36 EST
xorg-x11-6.8.2-1.EL.13.21 is now available for download and testing via
ftp at the following URL:  ftp://people.redhat.com/mharris/testing/4E

Please test this release as soon as possible, and provide feedback on the
results of testing in a status update.  If the problem is not resolved
after installing all of the rpm packages, and rebooting the system,
please set the bug back to "ASSIGNED" state.
Comment 11 Red Hat Bugzilla 2006-03-07 13:16:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0072.html

Note You need to log in before you can comment on or make changes to this bug.