Bug 167751 - Lack of clear method to update a diskless image used by system-config-netboot
Lack of clear method to update a diskless image used by system-config-netboot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 16:14 EDT by brian
Modified: 2010-04-06 07:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 07:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brian 2005-09-07 16:14:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
How do you update a diskless image used by system-config-netboot?

Seeing that RHEL is tied closely to RHN and up2date tools for getting updates into a RHEL installation I would like to look into how to get these tools working with the RHEL included system-config-netboot diskless environment.

Some ideas would be to work on up2date such that is is able to work out of a chrooted session of the diskless image run on the server offering the image out via nfs to the diskless client.  This would allow a simple cron type setup for getting updates applied to the image as well as manual option.  It would also work well in making the update as simple as these tools have made it for localy installed system in that it looks at what you have and updates only what is needed unless otherwise told.

Another option is to by hand download all RPMs related to the image we have that need to be updated and using rpm with the --root option to specify the image root.  This is a pain due to having to find all updates needed, insure they are downloaded and then handle a bit more manually the depenancy needs.

Last would be to find a way to get the RHN daemon running on the diskless image server to be able to be told about the image on this server and allow it to also check in for updates needed on that image and apply them as needed.  This is of my suggestions the most forward looking and also the most desireable being that we are an agressive RHN using site and very much like the benefits it offers.

The final point is simply a clean indication of how one is to manage updates/upgrades of a diskless image needs to be presented.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See description
2.
3.
  

Additional info:
Comment 1 brian 2005-09-13 15:35:16 EDT
In playing with a few thoughts on updates to an image I just tried something and
it looks to be working.  So I'm posting it here to get a response from someone
if this is a good or bad thing to be doing....

I chrooted into my diskless image and ran the following commands (edited for
personal info):

chroot /diskless/i386/RHEL4-AS/root/
rhnreg_ks --profilename=DisklessImage --username=NAME --password=PWD --force
rpm --import /usr/share/rhn/RPM-GPG-KEY
up2date-nox -u

After those commands were run the up2date command began doing the usual update
process or so it seems.  I know that after it is run I should rerun the gui on
the diskless image so that it can recheck the changes needed for diskless usage.
 That noted is this a complete method for updating or are there known issues I'm
not seeing that limits this method?
Comment 3 Jaroslav Reznik 2010-04-06 07:09:01 EDT
System-config-netboot is now in maintenance mode only, no further development
is planned for RHEL 4.x. Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.