Bug 167809 - Can't use XIM on XEmbed windows
Can't use XIM on XEmbed windows
Status: CLOSED DUPLICATE of bug 166068
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 09:15 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 01:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-09-08 09:15:36 EDT
+++ This bug was initially created as a clone of Bug #167808 +++

The upstream bug explains more:
https://bugs.freedesktop.org/show_bug.cgi?id=2006

The IM would freeze and events not be sent to the sub window. The problem also
shows in Java applets embedded in a web browser.

Patch as committed upstream attached:
http://cvs.freedesktop.org/xorg/xc/lib/X11/imEvToWire.c?r1=1.2&r2=1.3

The patch has been tested successfully.

-- Additional comment from bnocera@redhat.com on 2005-09-08 09:14 EST --
Created an attachment (id=118595)
xorg-x11-im-lockup.diff
Comment 1 Mike A. Harris 2005-09-12 17:11:30 EDT
Thanks for including the upstream bug URL, CVS commit, and patch.

The patch seems trivial enough, but we'll review it in more depth
during the RHEL4U3 development cycle, and update the bug with a
status update at that time.

Thanks again.


Note to whoever takes assignment of this during U3:

Check FC3/FC4/FC5 to see if this is present in those,
and fix there as well.  Push to upstream for 6.8.x branch if
not already present also.

Comment 2 Mike A. Harris 2005-09-14 01:23:27 EDT

*** This bug has been marked as a duplicate of 166068 ***
Comment 4 Mike A. Harris 2005-10-21 18:37:56 EDT
Devel ACK for U3.

Note You need to log in before you can comment on or make changes to this bug.