Bug 167814 - agpgart broken for intel 915G chipset on HP dc7100
agpgart broken for intel 915G chipset on HP dc7100
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 10:08 EDT by Stefan Rystedt
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 15:09:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Rystedt 2005-09-08 10:08:17 EDT
Description of problem:
Failing to load agpgart problebly releated with
bug 131907.

I do not know if it don not work for all 915G chipset or just the one
in the HP dc7100 series. Since when I do an lspci it will not recognize
the chipset. This is what lspci says:
lspci -v 

 00:00.0 Host bridge: Intel Corp. Memory Controller Hub (rev 04)
        Subsystem: Hewlett-Packard Company: Unknown device 3005
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] #09 [2109]
 
00:02.0 VGA compatible controller: Intel Corp. Graphics Controller (rev 04)
(prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company: Unknown device 3005
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at cfe00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Memory at cff00000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [d0] Power Management version 2
 
00:02.1 Display controller: Intel Corp. Graphics Controller (rev 04)
        Subsystem: Hewlett-Packard Company: Unknown device 3005
        Flags: bus master, fast devsel, latency 0
        Memory at cfe80000 (32-bit, non-prefetchable) [disabled] [size=512K]
        Capabilities: [d0] Power Management version 2

lspci -n
00:00.0 Class 0600: 8086:2580 (rev 04)
00:02.0 Class 0300: 8086:2582 (rev 04)
00:02.1 Class 0380: 8086:2782 (rev 04)

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.0.1.EL, kernel-smp-2.4.21-20.0.1.EL 

How reproducible:
always

Steps to Reproduce:
1.Try to load agpgart on a i810E equipped motherboard
2. fails

  
Actual results:
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 933M
agpgart: no supported devices found.


Expected results:
agpart to detect the 915G and start.
Comment 1 Brian Maly 2005-09-09 10:38:49 EDT
looks like it may be the same as bug 160009

we dont currently have code (2.4.21 kernels) in i386 to detect AGP peer busses,
although it exists in x86_64. the PCI code between i386 and x64_64 is different
but ideally should be more closely aligned.

Ill test my other patch (submitted to rhkernel to fix bug 160009) on this
hardware and see if it resolves this issue as well.

Note You need to log in before you can comment on or make changes to this bug.