Bug 167835 - kernel hangs when ping it with iptables enabled
kernel hangs when ping it with iptables enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 13:46 EDT by Vitali
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 05:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oops (510.21 KB, image/jpeg)
2005-09-24 17:01 EDT, Pekka Pietikäinen
no flags Details
dmesg of affected box (19.01 KB, text/plain)
2005-09-24 17:02 EDT, Pekka Pietikäinen
no flags Details

  None (edit)
Description Vitali 2005-09-08 13:46:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
When I starting to ping AMD64 with kernel-2.6.13-1.1542_FC5 host, it's hangs in the moment

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1542_FC5

How reproducible:
Always

Steps to Reproduce:
1. host1# /etc/init.d/iptables start
2. host2$ ping host1

  

Actual Results:  host1 hangs

Expected Results:  it should return ICMP reply

Additional info:
Comment 1 Dave Jones 2005-09-21 22:47:22 EDT
is this repeatable with todays updates ?
Comment 2 Vitali 2005-09-22 07:58:21 EDT
Dunno, you can get one of new development builds and check it out, but I don't
think that bug is still exist.
Comment 3 Pekka Pietikäinen 2005-09-24 16:11:34 EDT
I think bug is there still, I'm seeing similar in 1.1574_FC5, crashes quite
quickly after booting. Seems interrupt/timer related issues, traceback is full
of ip_ct_stuff, also I got 2^32 ms ping times for a while, then the box hung
while I started up X. Sometimes it crashes during the boot process itself. 

Netconsole didn't seem to work, acpi=off booted even worse (right after
detecting hda it just hung), so no traceback, will hunt for a serial cable...

Box is a nforce3-based x86_64, 1.1535_FC5 is rock-solid., I think it broke some
time around 1542 for me as well.
Comment 4 Pekka Pietikäinen 2005-09-24 17:00:44 EDT
Here's a calltrace (manually typed in, so skipping the addresses)

panic+11 kernel_text_address+28, show_trace+505, dump_stack+14
_spin_lock_irqsave+9, rwlock_bug, _raw_write_lock+58,
ip_conntrack:destroy_conntrack+109, conntrack: __ip_ct_event_cache_init+125
ip_ct_refresh_acct+211, udp_packet+38, ip_conntrack_in+956, poison_obj+49,
nf_iterate+89, dst_output+o, nf_hook_slow+95, dst_output+0,
ip_push_pending_frames+872...

Oh sod it, please see attachment (different occurrance of the bug)
Comment 5 Pekka Pietikäinen 2005-09-24 17:01:43 EDT
Created attachment 119228 [details]
Oops
Comment 6 Pekka Pietikäinen 2005-09-24 17:02:40 EDT
Created attachment 119229 [details]
dmesg of affected box
Comment 7 Dave Jones 2005-10-04 04:13:37 EDT
there were a bunch of netfilter fixes merged recently, can you retest ?
Comment 8 Pekka Pietikäinen 2005-10-04 04:21:54 EDT
Oops, forgot to report here as well, my problems vanished.

"Ok, it looks like that patch was the thing after all. I now tried the latest
fedora-devel kernel (1.1582, based on 2.6.14-rc2-git6) and the box has been
running for a few hours happily. Could be the fedora kernel that claimed to
be git4 actually wasn't, or the git4 changelog was really a post-git4
changelog :). But anyway, bug is gone."


Note You need to log in before you can comment on or make changes to this bug.