This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167883 - Get rid of up2date references in update mail
Get rid of up2date references in update mail
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 02:54 EDT by Luke Macken
Modified: 2016-09-19 22:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 14:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2005-09-09 02:54:59 EDT
Change footer of the update email template to include yum instructions, instead
of up2date.  This bug can be used as a drawing board for the replacement message.

Current Message:
This update can also be installed with the Update Agent; you can
launch the Update Agent with the 'up2date' command.
Comment 1 Bill Nottingham 2005-09-09 15:14:26 EDT
Perhaps something like:

This update can be installed with the 'yum' update program. Launch it via the
'yum' command. For more information, you may read the 'Managing Software with
yum' paper available at http://fedora.redhat.com/docs/yum/.

?
Comment 2 Karsten Wade 2005-09-09 18:22:35 EDT
Oh, my.  I never read down far enough to see the footer.  Luke, thanks for the
catch, we definitely want to steer people to yum.

How about these changes:

##
This update can be installed with the 'yum' update program.  Use 'yum update
package-name' at the command line.  For more information, refer to 'Managing
Software with yum,' available at http://fedora.redhat.com/docs/yum/.
##

When we have a yum GUI we feel good about, we'll want to put that in as well.
Comment 3 Rahul Sundaram 2005-09-09 18:26:03 EDT
Yumex and Kyum and are in Fedora Extras now. The newer versions of Yumex dont do
screen scrapping anymore. While the UI of these programs might not be where we
want them to be, I believe they do deserve atleast a passing mention but not
necessarily a strong recommendation. Any suggestions?
Comment 4 Bill Nottingham 2005-09-09 18:28:45 EDT
I think it's simpler to have the update instructions for Core only involve Core
packages, so as not to make it truly confusing. ICBW, though.
Comment 5 Karsten Wade 2005-09-09 18:32:16 EDT
Yeah, we need packages to be in Core to rely upon people having them by default.

A good place to put mentions of Yumex, Kyum, and others would be in the
'Software Management with yum' or a related document.

Since this should be an infrequently changing template, it's only worth changing
when we have a milestone such as the deprecation of up2date for Fedora, or the
advancement of a yum GUI into Core.
Comment 6 Luke Macken 2005-11-10 13:46:43 EST
Are we ready to make this template modification ?  Has up2date been *officially*
deprecated for Fedora yet ?
Comment 7 Rahul Sundaram 2005-11-10 13:54:47 EST
Additional note. Instead of directly pointing to the Yum document, you can
provide a reference to http://fedoraproject.org/wiki/Tools/yum instead.
Comment 8 Bill Nottingham 2005-11-10 14:01:44 EST
I think the docs project document is better suited for the announcement 
than the wiki page.
Comment 9 Patrick Barnes 2005-12-17 14:42:33 EST
How about this:

---------------------------------------------------------------------
This update can be installed with 'yum'.
Use 'yum update package-name' from a terminal as root.
More information is available online:
 http://fedora.redhat.com/docs/yum/ - Managing Software with yum
 http://fedoraproject.org/wiki/Tools/yum - yum introduction
---------------------------------------------------------------------
Comment 10 Luke Macken 2006-01-17 14:59:16 EST
(In reply to comment #2)
> ##
> This update can be installed with the 'yum' update program.  Use 'yum update
> package-name' at the command line.  For more information, refer to 'Managing
> Software with yum,' available at http://fedora.redhat.com/docs/yum/.
> ##

The up2date references have been removed from the email and the above message
has been added.  Thanks guys.

Note You need to log in before you can comment on or make changes to this bug.