Bug 168011 - "No theme index file" warning during %post
"No theme index file" warning during %post
Status: CLOSED DUPLICATE of bug 167957
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-10 14:18 EDT by Bill Crawford
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 01:18:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-09-10 14:18:29 EDT
Description of problem:
Error / warning messages during %post

Version-Release number of selected component (if applicable):
gnome-icon-theme-2.12.0-1

How reproducible:
Install or upgrade the package.

Actual results:

   1:gnome-icon-theme       ########################################### [100%]
No theme index file in '/usr/share/icons/Bluecurve-inverse'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/handhelds'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/locolor'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/redglass'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/whiteglass'.
If you really want to create an icon cache here, use --ignore-theme-index.
error: %post(gnome-icon-theme-2.12.0-1.noarch) scriptlet failed, exit status 1


Expected results:
Nothing :)

Additional info:
Also a problem were some empty directories in /usr/share/icons that appear to
have been left behind by kde packages that I've removed.
Comment 1 Bill Crawford 2005-09-10 14:21:03 EDT
I suspect that "--ignore-theme-index" might be the RTTD, but the empty lingering
directories are obviously a packaging problem.
Might it not be better to only run the gtk-update-icon-cache on directories that
were installed by the package itself?
Comment 2 Bill Crawford 2005-10-07 12:50:07 EDT
Still have a problem with latest rawhide release.

The %post scriptlet is calling gtk-update-icon-cache on directories that it
didn't install to, and thus picking on directories that don't have any
index.theme in, such as the ones installed by xcursor-themes, or
Bluecurve-inverse which belongs to redhat-artwork.

  Updating  : gnome-themes                 ##################### [103/278] 
No theme index file in '/usr/share/icons/Bluecurve-inverse'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/handhelds'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/locolor'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/redglass'.
If you really want to create an icon cache here, use --ignore-theme-index.
No theme index file in '/usr/share/icons/whiteglass'.
If you really want to create an icon cache here, use --ignore-theme-index.
Comment 3 Matthias Clasen 2005-10-12 01:18:28 EDT

*** This bug has been marked as a duplicate of 167957 ***

Note You need to log in before you can comment on or make changes to this bug.