Bug 168017 - system-config-printer generates traceback
Summary: system-config-printer generates traceback
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 168107 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-10 20:23 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 03:06:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
call iw_saether_ntop() instead of iw_pr_ether() (853 bytes, patch)
2005-09-12 19:31 UTC, Nalin Dahyabhai
no flags Details | Diff

Description Michal Jaegermann 2005-09-10 20:23:22 UTC
Description of problem:

After an update to system-config-printer-0.6.142-1 one sees from
/etc/init.d/cups which runs on a startup:

Starting cups: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 42, in ?
    import rhpl.ethtool
ImportError: /usr/lib/python2.4/site-packages/rhpl/ethtool.so: undefined symbol:
iw_pr_ether

Interestingly enough after that a status is reported as "OK".

Version-Release number of selected component (if applicable):
system-config-printer-0.6.142-1

How reproducible:
Always

Comment 1 Tim Waugh 2005-09-11 10:20:56 UTC
What version of rhpl?

Comment 2 Daniel Malmgren 2005-09-11 10:27:45 UTC
I can confirm this. I started getting it after upgrading rhpl to 0.170-1, using
the same s-c-p as Michal.

Comment 3 bastiaan 2005-09-11 20:46:07 UTC
system-config-network fails to startup because of the same missing symbol:
system-config-network-1.3.26-1 with rhpl-0.167-1 is OK, with  rhpl-0.170-1 it says:

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 64, in ?
    from netconfpkg.NC_functions import log
  File "/usr/lib/python2.4/site-packages/dbus/__init__.py", line 61, in ?

  File "<string>", line 1, in ?
  File
"/usr/src/build/556832-noarch/install/usr/share/system-config-network/netconfpkg/Control.py",
line 27, in ?
ImportError: /usr/lib/python2.4/site-packages/rhpl/ethtool.so: undefined symbol:
iw_pr_ether


Comment 4 Jonathan Kamens 2005-09-12 04:30:35 UTC
Changing status -- seems like requested info was provided.
This is happening to me too, with rhpl 0.170-1 and system-config-printer 0.6.142-1.


Comment 5 Jeremy Katz 2005-09-12 14:52:52 UTC
The ethtool module is calling private functions that seem to be gone in newer iwlib

Comment 6 Jeremy Katz 2005-09-12 15:47:36 UTC
*** Bug 168107 has been marked as a duplicate of this bug. ***

Comment 7 Nalin Dahyabhai 2005-09-12 19:31:05 UTC
Created attachment 118734 [details]
call iw_saether_ntop() instead of iw_pr_ether()

According to the changelog, the iw_pr_ether() function was renamed to
iw_saether_ntop(), and expects arguments in a different order.

Comment 8 Jeremy Katz 2005-09-13 03:06:11 UTC
Thanks Nalin -- applied and building


Note You need to log in before you can comment on or make changes to this bug.