Bug 168019 - Missing files - unable to find definition...
Summary: Missing files - unable to find definition...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-10 20:45 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 10:48:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2005-09-10 20:45:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
ALSA no longer works. Mplayer reports:

Checking audio filter chain for 48000Hz/6ch/s16le -> 48000Hz/6ch/s16le...
AF_pre: 48000Hz/6ch/s16le
alsa-init: 1 soundcard found, using: surround51
ALSA lib confmisc.c:990:(snd_func_refer) Unable to find definition 'cards.MPU-401 UART.pcm.surround51.0:CARD=0'
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3948:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2090:(snd_pcm_open_noupdate) Unknown PCM surround51
alsa-init: playback open error: No such file or directory
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...


Version-Release number of selected component (if applicable):
alsa-lib-1.0.9rf-3

How reproducible:
Always

Steps to Reproduce:
1. Enable ALSA sound for mplayer.
  

Additional info:

Comment 1 Martin Stransky 2005-09-12 15:04:56 UTC
Are you sure that your card has a support for 5+1 surround sound? Which driver
do you use?

Comment 2 Ivan Gyurdiev 2005-09-12 20:16:46 UTC
I am absolutely positive this card supports 5+1 surround.

This is snd_via82xx.
The card is:

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 50)

Comment 3 Martin Stransky 2005-09-13 05:36:18 UTC
Could you attach an output of 'aplay -l'?

Comment 4 Ivan Gyurdiev 2005-09-13 06:02:25 UTC
**** List of PLAYBACK Hardware Devices ****
card 1: V8235 [VIA 8235], device 0: VIA 8235 [VIA 8235]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 1: V8235 [VIA 8235], device 1: VIA 8235 [VIA 8235]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Comment 5 Martin Stransky 2005-09-13 06:45:10 UTC
What happens if you try:
aplay -D cards.VIA8233.pcm.surround51.0:CARD=0 /usr/share/sounds/phone.wav
aplay -D surround51 /usr/share/sounds/phone.wav


Comment 6 Martin Stransky 2005-09-13 06:47:47 UTC
Could you attach content of /proc/asound/cards?

Comment 7 Ivan Gyurdiev 2005-09-13 07:23:50 UTC
[phantom@cobra ~]$ aplay -D cards.VIA8233.pcm.surround51.0:CARD=0
/usr/share/sounds/phone.wav
aplay: main:533: audio open error: No such file or directory
[phantom@cobra ~]$ aplay -D surround51 /usr/share/sounds/phone.wav
ALSA lib confmisc.c:990:(snd_func_refer) Unable to find definition
'cards.MPU-401 UART.pcm.surround51.0:CARD=0'
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_refer returned
error: No such file or directory
ALSA lib conf.c:3948:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2090:(snd_pcm_open_noupdate) Unknown PCM surround51
aplay: main:533: audio open error: No such file or directory
[phantom@cobra ~]$

/proc/asound/cards:

0 [UART           ]: MPU-401 UART - MPU-401 UART
                     MPU-401 UART at 0x300, irq 5
1 [V8235          ]: VIA8233 - VIA 8235
                     VIA 8235 with ALC650F at 0xe400, irq 3

Comment 8 Martin Stransky 2005-09-13 08:10:23 UTC
You have to use the 'surround51:1' device instead of 'surround51'.

Comment 9 Ivan Gyurdiev 2005-09-13 08:16:30 UTC
That works.... so what's the bug?

Comment 10 Ivan Gyurdiev 2005-09-13 09:11:57 UTC
Hold on a moment.... that was not a rhethorical question.

There's a bug somewhere, because mplayer doesn't work. Furthermore, rhythmbox
doesn't work, and the multimedia system selector doesn't work. Any program using
ALSA doesn't work.... so I think the bug shouldn't be closed.

What exactly do you mean by "you should use surround 51:1". I am not familiar 
with how ALSA is configured - I don't care - I only want my frontend to work.
What change would you recommend to make the frontend(s) work?

Comment 11 Martin Stransky 2005-09-13 09:15:52 UTC
You have two soundcards but the primary (default) is the first one, i.e. UART.
Device surround51 means "use surround for the primary/default card" but your
primary card doesn't support it. Device surround51:1 means "use surround for the
secondary card", which is V8235 and it's the right card. You can change your
default card in /etc/asound.conf.

Comment 12 Ivan Gyurdiev 2005-09-13 09:32:50 UTC
I find this very strange, because, to the best of my knowledge I have one
soundcard, and not two. This soundcard is onboard. My soundcard supports 5.1
channel-audio. 

I see no /etc/asound.conf, and no manpage for it.
On the other hand I do see /etc/alsa/alsa.conf, but no manpage
for that either, and I don't understand the format.

I would expect sound to work out of the box on a Fedora install.

Comment 13 Martin Stransky 2005-09-13 10:23:03 UTC
You can use system-config-soundcard to set your primary soundcard and it will
make /etc/asound.conf for you.

Comment 14 Ivan Gyurdiev 2005-09-13 10:48:42 UTC
Allright, thank you...

So why is it that I have two soundcards (one of which doesn't work - I can't
hear Test sound)...



Note You need to log in before you can comment on or make changes to this bug.