Bug 168023 - gnome-system-log crash upon exit
gnome-system-log crash upon exit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-10 21:13 EDT by Luke Macken
Modified: 2016-09-19 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 11:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix gnome-system-log crash when no logs are open (by short-circuiting one of the conditionals) (437 bytes, patch)
2005-09-10 21:13 EDT, Luke Macken
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 316738 None None None Never

  None (edit)
Description Luke Macken 2005-09-10 21:13:25 EDT
Description of problem:
When opening the gnome-system-log as an unprivileged user (which is by default,
since it doesn't prompt for a superuser password), no logfiles are opened. 
Closing the gnome-system-log application with no log files open will then cause
a crash.

gdb provides me with this info:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209120224 (LWP 8792)]
0x08054c99 in destroy (object=0x9a91df8, data=0x9a91df8) at logview.c:221
221        if (window->curlog->monitored)

A patch to fix this issue is attached.

Version-Release number of selected component (if applicable):
gnome-utils-2.12.0-1 (issue in CVS as well)

How reproducible:
Always


Steps to Reproduce:
1. Open System Tools->System Log as a regular user
2. Close the application
  
Actual results:
Segfault.

Expected results:
Exit quietly.

Additional info:
This issue could also be resolved by prompting the user for the root password
before opening the program, which will launch it with a bunch of logfiles open,
thus alleviating the problem.
Comment 1 Luke Macken 2005-09-10 21:13:25 EDT
Created attachment 118683 [details]
Patch to fix gnome-system-log crash when no logs are open (by short-circuiting one of the conditionals)
Comment 2 Luke Macken 2005-09-20 11:25:57 EDT
----------------------------
revision 1.139
date: 2005/09/20 14:17:41;  author: vnoel;  state: Exp;  lines: +1 -1
2005-09-20  Vincent Noel  <vnoel@cox.net>

        * logview.c: Fix a crash when exiting without any log opened.
        Fix bug #316738. Patch from Luke Macken.
----------------------------

Note You need to log in before you can comment on or make changes to this bug.