Bug 168056 - Monitor-config miss-autoreadout on ATI rage 128 mobility card cuasing garbled display
Monitor-config miss-autoreadout on ATI rage 128 mobility card cuasing garbled...
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-09-11 17:20 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-15 14:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
What it looks like #1 (2.13 MB, image/jpeg)
2005-09-14 03:03 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2005-09-11 17:20:24 EDT
Description of problem:
After upgrading xorg today, the display is now garbeled when i boot by laptop.
It seems like it tried to output all three video outputs to the internal LCD
(the machine has three outputs - LCD, VGA, and s-video(? looks almost like a
ps/2 connector ?) out). This causes the display to "shake" (i can see it
scanning the screen), and three identical displays being partly overlayed, but
not the "correct" way. I will attach a photograph as soon as possible.

If i press "Fn-f8" (marked "CRT/LCD"), i get my display back to normal. I can
switch on/off the CRT/LCD output, so this works. Cannot test the TV-out as i
have no matching cable. Note that after "fixing" it with this button combo, i
cannot turn off LCD unless CRT is attached.

This happens when swithcing between console an X11, or when starting/stopping X11.

In console, it seems like it thinks that the display is *larger* than it should
  - the bottom output is below the physical screen boundary. A "clear" with a
CRT attached also "fixes" this. Also here the screen is "shaking".

This bug isn't completely new, as i have seen it before, also pre-fc4 and on
ubuntu. But now it happens completely unprovokedly. I have not tested the
CRT/LCD key combo before, so i cannot tell if it is new that this is working.
The "console to large" is also new, as it before used to having a "displaced
row"+"shaking", but now it has "shaking"+"to large"

Version-Release number of selected component (if applicable):

How reproducible:
Boot pc, or start X11. Also happens in RHGB

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "no"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1024x768"
        HorizSync    31.5 - 48.5
        VertRefresh  40.0 - 70.0
        Option      "dpms"

Section "Device"
        Identifier  "Videocard0"
        Driver      "r128"
        VendorName  "Videocard vendor"
        BoardName   "ATI Rage 128 Mobility"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "800x600" "640x480"
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"

Section "DRI"
        Group        0
        Mode         0666

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:03.0 CardBus bridge: Texas Instruments PCI1420
00:03.1 CardBus bridge: Texas Instruments PCI1420
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio
Accelerator (rev 10)
00:10.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus [Cyclone]
(rev 10)
00:10.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x
(rev 02)
Comment 1 Kyrre Ness Sjøbæk 2005-09-14 03:03:35 EDT
Created attachment 118790 [details]
What it looks like #1

As visible, the display is "split in three". Note that some things also comes
three times. (hosname, lower rigth corner).

Screenshot is of gdm, standard skin etc.
Comment 2 Olivier Baudron 2005-09-14 16:42:57 EDT
What was the last xorg version known to work on your laptop ?
Also, please attach your /etc/X11/xorg.conf and /var/log/Xorg.0.log.
Comment 3 Mike A. Harris 2005-09-14 16:57:35 EDT
Your system has multiple copies of rpms installed:


This looks like you have messed up your OS installation by using --nodeps
and/or --force when installing.  You'll need to do a fresh OS installation,
and update to the latest packages.

As a side note, please use bugzilla's file attachment feature instead of
pasting large files into the comment box, as it makes it easier to read
the bug report.

Thanks in advance.

Setting status to NEEDINFO_REPORTER, and waiting for results of fresh OS

Comment 4 Kyrre Ness Sjøbæk 2005-09-14 17:32:35 EDT
I have *never* used nodeps or force on the system. the duplication migth have
happened after i ran out of disk space during a "yum update". I shall first try
to clean out the double entries, and see if that works.

Note that the problem isn't new - i have even seen it on ubuntu. The new thing
is that it now happen everytime i start X11, not (sproradically) after switching
back/forth between X11 and text console.

What is the recomended method of installing rawhide, when anaconda is broken?
FC4 install and yum update?
Comment 5 Mike A. Harris 2005-09-14 18:07:07 EDT
(In reply to comment #4)
> I have *never* used nodeps or force on the system. the duplication migth have
> happened after i ran out of disk space during a "yum update". I shall first try
> to clean out the double entries, and see if that works.

Ok..  My main point though, is that your rpm database is messed up, and
perhaps your filesystem as well.  This means the system is in an unstable
state, which could have played a part in the problem.  When diagnosing a
bug report, the system must be in a known state, which is why I requested
an OS reinstall.

> Note that the problem isn't new - i have even seen it on ubuntu. The new thing
> is that it now happen everytime i start X11, not (sproradically) after switching
> back/forth between X11 and text console.

In this, it sounds like a generic bug in the X.Org r128 video driver,
and not a Red Hat specific bug.

Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 6 Kyrre Ness Sjøbæk 2005-09-15 10:11:59 EDT
Strange - i am not able to reproduce it anymore (?!?). It must have happened
after i played with some "fn-fx" combos while in Grub.

I shall reinstall the machine during the weekend, and if i am able to reproduce
after that. I can't even provoke the bug by repeatedly switching between VT and
X11 - only bug there is that the display something thinks that it should start
writing on the middle of the LCD instead of in upper rigth corner (it still fits
in though... But it "shakes" in one coloumn)- something fixed by fn-f7 (font -
often fn-F or "fullscreen", toggeling between 1:1 pixel rendering (not filling
out the entire display unless 1024*768).

Please leave this bug open at least a couple of weeks, so i can try and
reproduce it.

Comment 7 Mike A. Harris 2005-09-15 14:56:41 EDT
I prefer to close the bug, rather than have extraneous bugs piling up, but
if you can reproduce it in a couple of weeks, please follow the instructions
at the end of comment #5 above, and report it to X.Org bugzilla, then
paste the URL here to the Xorg bug report, and set the status here back
to REOPENED, and we'll track it.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.