Bug 16806 - /net automounting of all exported volumes broken
/net automounting of all exported volumes broken
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-23 13:20 EDT by mandrews
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 13:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mandrews 2000-08-23 13:20:37 EDT
Cool that /net even manages to occasionally work, but it fails to mount
hosts that do not export their root directory (/) - it looks like it fails
because it tries to create a directory without creating the parent
directory - for example here I tried to access /net/borg where borg does
not export /:

Aug 23 12:53:09 grinch automount[7625]: attempting to mount entry /net/borg
Aug 23 12:53:09 grinch automount[7668]: parse(sun):
dequote("fstype=nfs,hard,intr,nodev,nosuid  ^I/dsk/1 borg:/dsk/1  ^I/dsk/2
borg:/dsk/2  ^I/dsk/3
borg:/dsk/3  ^I/export borg:/export  ^I/exports borg:/exports  ^I/home
borg:/home") ->
fstype=nfs,hard,intr,nodev,nosuid                                                  
Aug 23 12:53:09 grinch automount[7668]: parse(sun): dequote("/dsk/1
borg:/dsk/1 ^I/dsk/2 borg:/dsk/2  ^I/dsk/3 borg:/dsk/3  ^I/export
borg:/export ^I/exports borg:/exports  ^I/home borg:/home") -> /dsk/1
Aug 23 12:53:09 grinch automount[7668]: parse(sun): dequote("borg:/dsk/1 
^I/dsk/2 borg:/dsk/2  ^I/dsk/3 borg:/dsk/3  ^I/export borg:/export 
^I/exports borg:/exports  ^I/home borg:/home") -> borg:/dsk/1
Aug 23 12:53:09 grinch automount[7668]: mount(nfs): mkdir_path borg/dsk/1
failed: Operation not permitted 


It looks like autofs also fails for some other hosts because it does not
sort the mounts correctly - here I try to access host "marvin" that does
export all its disks:

Aug 23 13:03:37 grinch automount[7625]: attempting to mount entry
/net/marvin
Aug 23 13:03:37 grinch automount[7784]: parse(sun):
dequote("fstype=nfs,hard,intr,nodev,nosuid  ^I/array marvin:/array 
^I/marvin:/  ^I/tmp marvin:/tmp") -> fstype=nfs,hard,intr,nodev,nosuid
Aug 23 13:03:37 grinch automount[7784]: parse(sun): dequote("/array
marvin:/array  ^I/ marvin:/  ^I/tmp marvin:/tmp") -> /array
Aug 23 13:03:37 grinch automount[7784]: parse(sun): dequote("marvin:/array
^I/ marvin:/  ^I/tmp marvin:/tmp") -> marvin:/array
Aug 23 13:03:37 grinch automount[7784]: mount(nfs): mkdir_path marvin/array
failed: Operation not permitted
Comment 1 Nalin Dahyabhai 2000-08-23 14:31:25 EDT
Host map support working correctly requires a 2.4 kernel, and the latest 4.0
prerelease doesn't work correctly under it.  Given those two things, we're
backing off to 3.1 for this release.  Please test the 3.1.5-5 packages in
http://people.redhat.com/nalin/test/ and see if you have any problems with it.
Comment 2 mandrews 2000-08-23 15:34:56 EDT
I installed autofs-3.1.5-5.i386.rpm and the /net mounts still do not work - I 
presume because I still have a 2.2 kernel. Is there an RPM for the 2.4 kernel? 
I do not seem to find any in the pinstripe distribution.
Comment 3 Nalin Dahyabhai 2000-08-23 16:02:33 EDT
There's no package for 2.4 kernels because the latest 4.0.0 prerelease no longer
works correctly with the 2.4 test kernels.  We'll release a 4.0 package after
2.4 is release and autofs 4.0 stabilizes to the point where the author considers
it release-quality.

Note You need to log in before you can comment on or make changes to this bug.