This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 168061 - bcm5700.o driver erratic on bcm5704 in Fujitsu Rx300 server
bcm5700.o driver erratic on bcm5704 in Fujitsu Rx300 server
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 22:25 EDT by Nathan B
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 16:10:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan B 2005-09-11 22:25:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
This bug deals with the Broadcom bcm5700 module, not bcm5820

The ethernet port behaves as expected for most of the time. Randomly, usually when there has been no network activity on the server for a while, logging in via HTTP or SSH causes the connection to be initally dropped. Trying again shortly after results in being able to connect.

I have noticed this on Fujitsu RX300 hardware, using their kernel upgrade kit. They aren't supporting the module since they didn't make it. I upgraded to 2.4.21-20.EL and 2.4.21-32.0.1.EL respectively, and since both kernels use the same module, the same issue happened randomly. Earlier kernels did not display the same problem (I think the earlier module version is different or something)

This isn't a firewall issue. I have disabled lokkit. Nor is this a network issue as I reproduced the error with a direct connection to the ethernet port.

A look in dmesg shows that the module being loaded is bcm5700.o ver 7.3.5, and that the actual hardware found on the server is bcm5704. Seems to detect the ethernet ports twice as well.



Version-Release number of selected component (if applicable):
kernel-2.4.21-20.ELsmp, kernel-2.4.21-32.0.1.ELsmp

How reproducible:
Sometimes

Steps to Reproduce:
1. Installation of RedHat ES 3 as per Fujitsu instruction manual. A boot disk is required initially to load the dpt_i2o module and the bcm5700 module.
2. Upgrade kernel to newer version, with updated bcm5700 module. Execute mkinitrd and depmod, and successfully reboot system. 
3. (and now for the hard part) waiting until the server finally drops a packet while you try to ssh into it.


Actual Results:  Randomly the server drops my inital ssh connection as I try to log in. Not always reproducable, but noticable after a while.

Expected Results:  It shouldn't be dropping any connections whatsoever.

Additional info:

dmesg output:

-------------------------------------------------
Broadcom Gigabit Ethernet Driver bcm5700 with Broadcom NIC Extension (NICE) ver.
 7.3.5 (06/23/04)
divert: allocating divert_blk for eth0
eth0: Broadcom BCM5704 1000Base-T found at mem fa010000, IRQ 18, node addr 00300
5815bc5
eth0: Broadcom BCM5704 Integrated Copper transceiver found
eth0: Scatter-gather ON, 64-bit DMA ON, Tx Checksum ON, Rx Checksum ON, 802.1Q V
LAN ON, NAPI ON
divert: allocating divert_blk for eth1
eth1: Broadcom BCM5704 1000Base-T found at mem fa030000, IRQ 19, node addr 00300
5815bc6
eth1: Broadcom BCM5704 Integrated Copper transceiver found
eth1: Scatter-gather ON, 64-bit DMA ON, Tx Checksum ON, Rx Checksum ON, 802.1Q V
LAN ON, NAPI ON
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (8192 buckets, 65536 max) - 304 bytes per conntrack
Broadcom Gigabit Ethernet Driver bcm5700 with Broadcom NIC Extension (NICE) ver.
 7.3.5 (06/23/04)
divert: allocating divert_blk for eth0
eth0: Broadcom BCM5704 1000Base-T found at mem fa010000, IRQ 18, node addr 00300
5815bc5
eth0: Broadcom BCM5704 Integrated Copper transceiver found
eth0: Scatter-gather ON, 64-bit DMA ON, Tx Checksum ON, Rx Checksum ON, 802.1Q V
LAN ON, NAPI ON
divert: allocating divert_blk for eth1
eth1: Broadcom BCM5704 1000Base-T found at mem fa030000, IRQ 19, node addr 00300
5815bc6
eth1: Broadcom BCM5704 Integrated Copper transceiver found
eth1: Scatter-gather ON, 64-bit DMA ON, Tx Checksum ON, Rx Checksum ON, 802.1Q V
LAN ON, NAPI ON
bcm5700: eth0 NIC Link is UP, 100 Mbps half duplex
Comment 1 John W. Linville 2005-09-16 16:22:22 EDT
I'm really sorry, but I can't support the bcm5700 driver in RHEL3 (or beyond).  
The preferred (and only supported) driver for that hardware is tg3.  You'll 
have to switch to using the tg3 driver to get support. 
 
Edit /etc/modules.conf and change any occurrences of "bcm5700" with "tg3".  If 
you are using any module options for the bcm5700, please remove those lines 
from /etc/modules.conf completely. 
 
Please reboot after making those changes and attempt to recreate the issue.  
Please post the results of your testing here.  Also, if you still experience 
this issue then please try again using the kernels here: 
 
   http://people.redhat.com/linville/kernels/rhel3/ 
 
Those kernels have an even later version of the tg3 driver. 
 
Thanks in advance for your cooperation! 
Comment 2 John W. Linville 2005-10-31 16:10:57 EST
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.