Bug 168089 - device IP not requested via DHCP for longer than one minute
device IP not requested via DHCP for longer than one minute
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 07:15 EDT by Jarkko
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 13:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2005-09-12 07:15:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
From /var/log/messages:

--
Sep 12 07:43:50 porkkana dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Sep 12 07:46:10 porkkana kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Sep 12 07:46:10 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
Sep 12 07:46:10 porkkana dhclient: receive_packet failed on eth0: Network is down
Sep 12 07:46:16 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
Sep 12 07:46:27 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
Sep 12 07:46:45 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 16
Sep 12 07:47:01 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
Sep 12 07:47:10 porkkana dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 1
--

Network went down at 07:46:10. It came up at 09:20, but this server never got back. The reason for this is that the server stopped from trying one minute later the network went down.

Version-Release number of selected component (if applicable):
initscripts-7.93.7-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Set up eth0 to use DHCP
2. Disconnect the network
3. See the server stopping from trying after one minute
  

Actual Results:  The server stopped from trying after one minute from the network "crash".

Expected Results:  The server should have been trying to send DHCPDISCOVER and not stop - ever.

Additional info:
Comment 1 Bill Nottingham 2005-09-12 13:19:25 EDT
Generally, interfaces are configured to only check for an IP address once.

Later releases are configurable (see PERSISTENT_DHCLIENT in sysconfig.txt).

Note You need to log in before you can comment on or make changes to this bug.