This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 16811 - Kernel won't compile after recommended upgrade to 2.2.16-3
Kernel won't compile after recommended upgrade to 2.2.16-3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 17717 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-23 14:00 EDT by bradley
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 20:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bradley 2000-08-23 14:00:06 EDT
kernel will not compile after upgrading kernel packages 
to 2.2.16-3  Followed the Red Hat kernel upgrade howto
make oldconfig  <--------OK
make dep          <--------OK
make zImage      <------FAILS

Complains about not being able to find linux/errno.h
Although the file does exist.

Try it

--
Brad
Comment 1 Michael K. Johnson 2000-08-23 16:24:21 EDT
Make sure that the /usr/include/asm and /usr/include/linux
symlinks still point to the right place.
Comment 2 Kevin 2000-09-01 03:34:11 EDT
Same problem. The symlinks are not recreated during the upgrade and need to be added manually.
Comment 3 Need Real Name 2000-09-06 13:54:32 EDT
I have the same exact problem.  Other things will not compile also.  I got the 
error compiling php4.0.2
Comment 4 Jakub Jelinek 2000-09-23 00:31:39 EDT
*** Bug 17717 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.