Bug 168117 - sound continues even after tvtime exits
sound continues even after tvtime exits
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tvtime (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 13:21 EDT by Andre Robatino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 04:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2005-09-12 13:21:14 EDT
Description of problem:
  After exiting tvtime, sound continues.  This didn't happen with the original
FC4 version.  I remember that in a previous version of FC, this also happened.

Version-Release number of selected component (if applicable):
tvtime-1.0.1-0.fc4.1

How reproducible:
always

Steps to Reproduce:
1.  Run tvtime.
2.  Exit tvtime.
  
Actual results:
  Sound continues.

Expected results:
  Sound should stop.

Additional info:
  ATI TV-Wonder VE tuner card
Comment 1 Marc Thompson 2005-09-16 23:23:07 EDT
I can confirm the same problem, with the same steps to reproduce, and the same
tuner card.  When I switch back to the previous version of tvtime the tv sound
shuts off as it should when I exit tvtime.
Comment 2 Andre Robatino 2005-09-17 02:03:27 EDT
  It may have something to do with the fact that the "m" key doesn't work for
muting with this card, but the "," key does.  I read a long time ago that it has
something to do with lack of hardware support for muting in this card.  The ","
key is supposed to toggle between normal and zero volume, and it usually does. 
In particular, I can use it to mute the sound just before exiting tvtime. 
However, after starting tvtime, it doesn't work for restoring volume, and I have
to hold down the right arrow key to push volume back up to 100%.  After that it
works normally again.
Comment 3 Andre Robatino 2005-09-17 03:56:17 EDT
  Here is a bug report from Sourceforge for what looks like the same problem, so
maybe it's independent of the card.

http://sourceforge.net/tracker/index.php?func=detail&aid=1292590&group_id=64301&atid=506987
Comment 4 Andre Robatino 2005-09-17 11:15:05 EDT
  See the latest comments at the above link for the fix.  It turns out that a
default setting was changed, and editing ~/.tvtime/tvtime.xml to change the
default back fixes the problem.  Namely, add the line

    <option name="MuteOnExit" value="1"/>

(the default used to be 1 but now it's 0).  Hence it's not really a bug, though
the fix should be better documented.
Comment 5 Marc Thompson 2005-09-18 21:25:40 EDT
Thank you, Andre!  Adding the line

<option name="MuteOnExit" value="1"/>

to the ~/.tvtime.xml file did the trick.
Comment 6 Andre Robatino 2005-09-19 04:17:01 EDT
  I'm closing this as NOTABUG since it's not really a bug, though the cause and
fix should be better documented.  If other people then file duplicate reports,
maybe it should be reopened as an enhancement request for better documentation.

Note You need to log in before you can comment on or make changes to this bug.