Bug 168165 - Obsolete description text reference: pump
Obsolete description text reference: pump
Status: CLOSED WORKSFORME
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 00:25 EDT by Jan Kratochvil
Modified: 2016-09-19 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 21:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update announcement mail (5.91 KB, message/rfc822)
2005-09-13 22:17 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2005-09-13 00:25:11 EDT
Description of problem:
You are referencing in %description "pump" while it is called "dhclient" now.

Version-Release number of selected component (if applicable):
dhcp-3.0.2-22.FC4

How reproducible:
always

Steps to Reproduce:
1. rpm -qi dhcp

Actual results:
...
You will also need to install the pump package, which
provides the DHCP client daemon, on client machines.

Expected results:
...
You will also need to install the dhclient package, which
provides the DHCP client daemon, on client machines.

Additional info:
Comment 1 Jason Vas Dias 2005-09-13 11:11:03 EDT
I'm not sure where 'rpm -qi' is getting its information for this query.

The dhcp.spec description, on both Rawhide and FC-4, is :
"
%description
DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
individual devices on an IP network to get their own network
configuration information (IP address, subnetmask, broadcast address,
etc.) from a DHCP server. The overall purpose of DHCP is to make it
easier to administer a large network.  The dhcp package includes the
ISC DHCP service and relay agent.

To use DHCP on your network, install a DHCP service (or relay agent),
and on clients run a DHCP client daemon.  The dhcp package provides
the ISC DHCP service and relay agent.

%description -n dhclient
DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
individual devices on an IP network to get their own network
configuration information (IP address, subnetmask, broadcast address,
etc.) from a DHCP server. The overall purpose of DHCP is to make it
easier to administer a large network.

To use DHCP on your network, install a DHCP service (or relay agent),
and on clients run a DHCP client daemon.  The dhclient package 
provides the ISC DHCP client daemon.

%description devel
Libraries for interfacing with the ISC DHCP server.
'

As you can see, the word 'pump' does not exist in the current dhcp.spec
for FC-4 or Rawhide - nor for any RHEL release for that matter.

Please do:

# rpm -qa | grep dhcp

I think you'll find that you have a different dhcp package to the one we ship
installed.
Comment 2 Jan Kratochvil 2005-09-13 22:17:27 EDT
Created attachment 118784 [details]
Update announcement mail

OK, sorry, my "rpm -qi" says it right. I cheated by saying "rpm -qi".
My text comes from the announcement on <fedora-announce-list@redhat.com>,
Message-ID <200509130358.j8D3wEL3025118@devserv.devel.redhat.com>,
attached, which says:

Product     : Fedora Core 4
Name	    : dhcp
Version     : 3.0.2
Release     : 22.FC4
...
network. You will also need to install the pump package, which
provides the DHCP client daemon, on client machines.

Dunno where the announcements making script takes its source files, though.
But somewhere still IS a bug.
Comment 3 Jason Vas Dias 2005-09-19 13:57:13 EDT
Sorry for the confusion - it appears that yes, this is NOT a bug with dhcp -
no dhcp.spec file contains the word "pump" . But it appears the machine which
generates the Fedora Update emails has an out-of-date "specspo" package
installed, which overrides the %{DESCRIPTION} from the dhcp.spec file -
reassigning.
Comment 6 Luke Macken 2006-05-17 21:12:45 EDT
Long since fixed.

Note You need to log in before you can comment on or make changes to this bug.