Bug 168169 - scim deactivate automatically when using openoffice edit .doc file
scim deactivate automatically when using openoffice edit .doc file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 02:05 EDT by Qingyu Wang
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 22:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qingyu Wang 2005-09-13 02:05:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7.10) Gecko/20050909 Red Hat/1.0.6-1.4.2 Firefox/1.0.6

Description of problem:
When using scim input in openoffice in RHEL 4, sometimes scim will be disable automatically. I must restart openoffice to activate scim again. At first I thought it will happen in openoffice irregularly, yet after test I find this bug just happens when I edit *.doc files(which are saved by Microsoft word) using openoffice. When using openoffice edit general file such as .sxw file, this problem won't happen. And I try XIM and IIIMF in the same situation, when I input with XIM the same bug happened, yet when with IIIMF, it seems that everything is OK. 

Version-Release number of selected component (if applicable):
scim-1.4.2, RHEL 4

How reproducible:
Sometimes

Steps to Reproduce:
1. Open a .doc file which is saved as Microsoft word document;
2. Activate scim and input chinese and edit in the .doc file;

  

Actual Results:  scim will be disable automatically sometimes when edit .doc fine using openoffice, and user must restart openoffice to activate scim again.

Expected Results:  input Chinese and edit .doc file in oponoffice normally

Additional info:
Comment 1 Qingyu Wang 2005-09-13 22:50:14 EDT
This bug occured because I unset the environment variable GTK_IM_MODULE, after I
set GTK_IM_MODULE=scim the bug disappeared.
Comment 2 Warren Togami 2005-09-18 23:58:42 EDT
qwang, just verifying, did you file the bug against RHEL4 openoffice.org where
XIM is broken?
Comment 3 Qingyu Wang 2005-09-19 10:05:39 EDT
yeah, I filed the bug against RHEL4 openoffice.org just now, bug 168676

Note You need to log in before you can comment on or make changes to this bug.