Bug 168183 - folder_hook push broken
folder_hook push broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 06:33 EDT by Thomas Zehetbauer
Modified: 2014-07-29 07:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-29 07:01:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2005-09-13 06:33:21 EDT
The currently only and recommended way to specify a default limit pattern
(message filter) is a folder_hook with a push command. Unfortunately this breaks
POP/IMAP authentication, because the hook is executed before login has succeeded
and the keyboard buffer is used by the password prompt. Example:
folder-hook . push "l!~D<enter>

This bug has already been fixed in upstream as of 2005-08-07. Unfortunately mutt
seems to have one of the most conservative release policies, because 1.5 is
still marked "development" while the last stable 1.4 release dates back more
than 19 months!
Comment 1 Oliver Andrich 2005-12-31 17:18:10 EST
Well, I am about to setup a ticket asking for inclusion of mutt 1.5.x into
fedora core. Even the less progressive guys of debian fame are using a 1.5.9.
Most of the fixes applied to the 1.4.2 source tree inside the rpm are also
already included. May be we also do the transition to 1.5. Even if it is a
"development" version.
Comment 2 Miroslav Lichvar 2007-02-07 09:56:02 EST
mutt-1.5 is in rawhide now.
Comment 3 jpacner 2014-07-23 10:07:52 EDT
List of patches present on mutt-1.5.20-6.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=7c9fc75e4d08207e32427bd3d153b8b380eb8efb
Comment 4 jpacner 2014-07-29 07:02:56 EDT
Recovered from unwanted changes caused by a badly chosen bug number choice.

Note You need to log in before you can comment on or make changes to this bug.