Bug 168215 - mtr SRPM has a missing buildreq of gtk+-devel
mtr SRPM has a missing buildreq of gtk+-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 12:01 EDT by Roozbeh Pournader
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-10 10:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem (524 bytes, patch)
2005-09-13 12:01 EDT, Roozbeh Pournader
no flags Details | Diff

  None (edit)
Description Roozbeh Pournader 2005-09-13 12:01:02 EDT
Description of problem:
mtr SRPM has a missing buildreq of gtk+-devel. The problem is in both Rawhide
and FC4 packages. Attached a patch.

Version-Release number of selected component (if applicable):
mtr-0.69.3

How reproducible:
Always

Steps to Reproduce:
1. Remove the gtk+-devel package.
2. rpmbuild -ba mtr.spec
  
Actual results:
The build fails with an error ending in:

+ aclocal
aclocal:configure.in:64: warning: macro `AM_PATH_GTK' not found in library
+ automake -a
+ autoconf
configure.in:64: error: possibly undefined macro: AM_PATH_GTK
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Expected results:
It should fail mentioning the gtk+-devel requirement.
Comment 1 Roozbeh Pournader 2005-09-13 12:01:03 EDT
Created attachment 118758 [details]
Patch to fix the problem
Comment 2 Phil Knirsch 2005-10-10 10:19:09 EDT
Fixed in latest development version.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.